Opened 12 years ago

Closed 7 years ago

Last modified 7 years ago

#1640 closed bug (fixed)

Drag&drop between icon-wells

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/FileTypes Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is in vmware, hrev22979.

Open the FileType Add-on of some file, e.g. any text file. Now open the FileType Add-On of some file, that has it's own icon, e.g. an app like CDPlayer. Or open the FileTypes Preferences and look for an icon there.

Now drag&drop one "icon-well" to the other, thereby assigning that icon to that file. The panel itself doesn't show that anything has happened, though it did work. The icon-well is only updated after the FileType Add-on is reopened.

Also note the highlighting of the icon-well on mouse over: sometimes it's a white frame, sometimes it's black. Also it's sometimes difficult to get focus to the icon-well to initiate the drag&drop.

Change History (7)

comment:1 by aldeck, 11 years ago

hrev28314 here.

Seems the drag/drop issue has been fixed by stippi around hrev28159. (note that you need to restart tracker to see the updated file icon, but i think there's a ticket for that one)

As for the drag being hard to initiate, i had this problem too but i didn't look at it yet. The hiliting drop frame might be too small with regard to the icon also.

comment:2 by aldeck, 11 years ago

replying to myself, Well, it's not fixed when using FileType on non-executables. And apparently the icon in tracker is updated but only if it's on the desktop.

comment:3 by mmadia, 7 years ago

See #1868 -- possible dupe.

comment:4 by stpere, 7 years ago

Hi, this is fixed hrev44503. Thanks!

in reply to:  4 comment:5 by mmadia, 7 years ago

Resolution: fixed
Status: newclosed

Replying to stpere:

Hi, this is fixed hrev44503. Thanks!

comment:6 by humdinger, 7 years ago

The main point of the ticket is solved, thanks! I still see what's described in the last paragraph of the ticket:

Also note the highlighting of the icon-well on mouse over: sometimes it's a white frame, sometimes it's black. Also it's sometimes difficult to get focus to the icon-well to initiate the drag&drop.

That white frame appears on first mouse-over when you drag from another icon well. Don't drop the icon, but move away from the icon well and come back to it. Now the frame is black. No big deal really.

After a successfull drag&drop, remove the icon again and repeat the drag&dropping. Often you can't grab the icon (no focus?).

comment:7 by stpere, 7 years ago

Regarding the second part (except for the border thing..), I'm investigating if it's a duplicate of #6861.

Note: See TracTickets for help on using tickets.