Opened 12 years ago

Closed 7 years ago

#1868 closed bug (fixed)

Icon changing using the File Type Icon drop doesn't update in dialog box

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/FileTypes Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using the drag and drop trick of dragging an application's icon onto the icon square in the File Type box to change the icon DOES change the apps icon, but the icon shown in the File Type dialog box doesn't update until you close it and then reopen it. Screenshot shows a trashcan icon, which was the previous icon I had assigned to my BeOS Max volume. (No files were harmed in this test... I hope).

Attachments (1)

filetype-icon-update-laggs.png (129.3 KB ) - added by scottmc 12 years ago.

Download all attachments as: .zip

Change History (7)

by scottmc, 12 years ago

comment:1 by axeld, 12 years ago

Component: - GeneralPreferences/FileTypes

I can only reproduce this with volumes. Can you do this with other types as well? And if so, how exactly and using which files?

comment:2 by scottmc, 11 years ago

I was only able to get that to happen with volumes.

comment:3 by scottmc, 11 years ago

This seems to have changed on recent builds? Now if I try dropping a different icon for a file it updates the files icon right away, but the icon drop box instead of not updating the icon box is it just left empty. I'd expect to see the new icon there. I only have a single volume here so I wasn't able to check to see if non-boot volume icons are still acting as they were when this ticket was filed.

comment:4 by aldeck, 11 years ago

on hrev28314, can only reproduce running FileType on a non-executable. It works well on applications with the bigger "Application Type" dialog.

comment:5 by mmadia, 7 years ago

See #1640 -- possible dupe.

comment:6 by stpere, 7 years ago

Resolution: fixed
Status: newclosed

Should be fixed in hrev44503, thanks!

Note: See TracTickets for help on using tickets.