Opened 12 years ago

Closed 12 years ago

#1654 closed bug (fixed)

Text file empty(?) after copying

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is in vmware, hrev23003

This is a strange bug I have experienced for quite some revisions. Probably ever since I use a UserBootscript.

Before updating to a new vmware image, I backup the ~/config folder to a second BFS-image. After updating the Haiku image, I mount that image and simply copy back the backuped config folder, overwriting the existing one. Note, that there isn't yet a ~/config/boot folder in the default Haiku image.

Now to the strange part: After copying the whole backuped config folder the UserBootscript is always shown empty ("cat UserBootscript" returning nothing) but is reported with the correct size (496 bytes). If copy the backuped UserBootscript alone into ~/config/boot it's all there.

I have no idea if any other files are suffering the same problem. Only with the UserBootscript you notice it at once as it's not executed at startup...

I attached the mamed UserBootscript.

Attachments (1)

UserBootscript.zip (412 bytes ) - added by humdinger 12 years ago.
Text file appearing empty, size 496 bytes

Download all attachments as: .zip

Change History (3)

by humdinger, 12 years ago

Attachment: UserBootscript.zip added

Text file appearing empty, size 496 bytes

comment:1 by humdinger, 12 years ago

This issue has apparently been solved while I was MIA the past weeks. Thanks very much.

comment:2 by axeld, 12 years ago

Component: Applications/TrackerSystem/Kernel
Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.