Opened 12 years ago

Closed 12 years ago

#1658 closed bug (invalid)

KDL: when tracker is trying to show the /dev contents

Reported by: kaoutsis Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description


Attachments (1)

KDL-tracker-dev.txt (2.8 KB ) - added by kaoutsis 12 years ago.

Download all attachments as: .zip

Change History (6)

by kaoutsis, 12 years ago

Attachment: KDL-tracker-dev.txt added

comment:1 by mmu_man, 12 years ago

Is it a gcc2.95 build ? I have the same crash here at boot, when it loads network drivers. I rebuild the kernel with TRACE_ELF and here's what I get:

elf_load_kspace: entry path '/boot/beos/system/add-ons/kernel/drivers/dev/net/ipro1000'
reading in program headers at 0x34, length 0x60
looking at program header 0
elf_load_kspace: created area "ipro1000_text" at 0x905b5000
looking at program header 1
elf_load_kspace: created area "ipro1000_data" at 0x905e6000
looking at program header 2
top of elf_parse_dynamic_section
needed_offset = -1873054701
top of elf_relocate
total 241 relocs
total 63 plt-relocs
vm_soft_fault: va 0x211ed8d8 not covered by area in address space

in reply to:  1 comment:2 by kaoutsis, 12 years ago

Replying to mmu_man:

Is it a gcc2.95 build ?

yes, it is: $ uname -a BeOS trantor 5.0 1000009 BePC unknown $ gcc -v using priority 5 Reading specs from /boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-beos/2.95.3-beos-060710/specs gcc version 2.95.3-beos-060710 $

comment:3 by axeld, 12 years ago

I can't reproduce this here. Are you sure you are using the latest revision? There were a few bugs in the fs_shell, as well as the kernel that could have been responsible for that.

in reply to:  3 ; comment:4 by kaoutsis, 12 years ago

Replying to axeld:

I can't reproduce this here. Are you sure you are using the latest revision? There were a few bugs in the fs_shell, as well as the kernel that could have been responsible for that.

you may be right; i will build the whole tree from scratch, since i get now a kdl from net_server. I suspect that the problem may be that sometimes the building process fails at removing attributes, cpu is at 100%, i can not kill this process (on hrev5), then i reboot; however the partitions are sometimes (after the failed build) not in a good shape: some object files have become syslinks, and etc weird thinks.

i will post back after the new build:)

in reply to:  4 comment:5 by kaoutsis, 12 years ago

Resolution: invalid
Status: newclosed

Replying to kaoutsis:

Replying to axeld:

I can't reproduce this here. Are you sure you are using the latest revision? There were a few bugs in the fs_shell, as well as the kernel that could have been responsible for that.

you may be right; i will build the whole tree from scratch, since i get now a kdl from net_server. I suspect that the problem may be that sometimes the building process fails at removing attributes, cpu is at 100%, i can not kill this process (on hrev5), then i reboot; however the partitions are sometimes (after the failed build) not in a good shape: some object files have become syslinks, and etc weird thinks.

i will post back after the new build:)

you were right; both the "/dev" and "net_server" issue are no longer exist.

Note: See TracTickets for help on using tickets.