Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#166 closed bug (fixed)

app_server crash after several minutes of incativites

Reported by: diver Owned by: axeld
Priority: critical Milestone: R1
Component: - General Version:
Keywords: Cc: j_freeman@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Dunno if it happens nativly, but in latest wmvare it already crashed about 10 times with the same error. This happens If you boot haiku, then switch to another task for ex. to filed up a bug here, and then return to running haiku and try to click on some menus or, like in this case, Deskbar menu. Tested with rev16392. Screenshot will follow.

Attachments (5)

crash.PNG (44.6 KB) - added by diver 13 years ago.
sc of Haiku crash
another_crash.PNG (36.1 KB) - added by diver 13 years ago.
Another variation of same bug i think
after_restart.PNG (14.0 KB) - added by diver 13 years ago.
serveral seconds later after previous shot (hot restart)
after_another_restart.PNG (29.3 KB) - added by diver 13 years ago.
YAS
haiku_rev16399.png (37.8 KB) - added by j_freeman@… 13 years ago.
Rev. 16399

Download all attachments as: .zip

Change History (20)

Changed 13 years ago by diver

Attachment: crash.PNG added

sc of Haiku crash

Changed 13 years ago by diver

Attachment: another_crash.PNG added

Another variation of same bug i think

Changed 13 years ago by diver

Attachment: after_restart.PNG added

serveral seconds later after previous shot (hot restart)

Changed 13 years ago by diver

Attachment: after_another_restart.PNG added

YAS

comment:1 Changed 13 years ago by jackburton

Last two screenshots show different bugs. You should file a bug for each one.

This http://haiku-os.org/bugzilla/attachment.cgi?id=44 Is not even a kernel bug, as only the app_server crashes.

comment:2 Changed 13 years ago by diver

attachments.isobsolete: 01

comment:3 Changed 13 years ago by diver

Followed Stefano suggestion and file two different bugs. Thanks Stefano. Is there a way to delete wrong attachments?

comment:4 Changed 13 years ago by j_freeman@…

(From update of attachment 55) I'm not sure if this is related, but it might be some help to one of the developers.

Changed 13 years ago by j_freeman@…

Attachment: haiku_rev16399.png added

Rev. 16399

comment:5 Changed 13 years ago by diver

Component: KernelServers

comment:6 Changed 13 years ago by diver

Summary: Haiku crash after several minutes of incativitesapp_server crash after several minutes of incativites

comment:7 Changed 13 years ago by korli

* Bug 202 has been marked as a duplicate of this bug. *

comment:8 Changed 13 years ago by korli

Cc: j_freeman@… added

comment:9 Changed 13 years ago by j_freeman@…

To the developers (or anyone who knows the answer), how can we know if future bugs that trigger KDL are a variant of this particular bug? Is it the "get_physical_page_tmap failed" part? That is the only thing I see that is the same between all of these screenshots.

comment:10 Changed 13 years ago by axeld

Status: newassigned

comment:11 Changed 13 years ago by axeld

This bug has been fixed in the last week and will be committed shortly :)

comment:12 Changed 13 years ago by axeld

Fixed with hrev16511.

comment:13 Changed 13 years ago by axeld

Resolution: fixed

comment:14 Changed 13 years ago by axeld

Status: assignedclosed

comment:15 Changed 13 years ago by marcusoverhagen

finally works here, too

Note: See TracTickets for help on using tickets.