Opened 12 years ago

Closed 12 years ago

#1690 closed bug (fixed)

StyledEdit cost 100% CPU when open files

Reported by: anthonylee Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: andreasf
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I just open one file in StyledEdit, it worked fine.

Then I double click another file in Tracker in order to be opened by StyledEdit, in the mean time, StyledEdit cost 100% CPU and seemed through into dead-lock state or dead cycle.

Attachments (1)

cwstring.pp (19.5 KB ) - added by oco 12 years ago.
Here is a file to reproduce this bug

Download all attachments as: .zip

Change History (9)

comment:1 by korli, 12 years ago

I can't reproduce. Could you elaborate ?

comment:2 by anthonylee, 12 years ago

I can't reproduce again because updated to SVN version lately, so I guess it's not a bug of StyledEdit.

Just don't know what's the problem before, sorry.

Thanks.

comment:3 by andreasf, 12 years ago

Cc: andreasf added

I occasionally get this, too. Not reproducibly though.

comment:4 by nielx, 12 years ago

Testing comment.

by oco, 12 years ago

Attachment: cwstring.pp added

Here is a file to reproduce this bug

comment:5 by jackburton, 12 years ago

Owner: changed from korli to jackburton

comment:6 by jackburton, 12 years ago

Component: Applications/StyledEditKits/Interface Kit
Status: newassigned

Looks like the culprit is BTextView::_RecalculateLineBreaks().

comment:7 by korli, 12 years ago

Also when testing with Dano StyledEdit, I noticed it kept the document at its position (somehow) when activating/deactivating word wrapping, whereas Haiku StyledEdit reset the position at the beginning.

comment:8 by jackburton, 12 years ago

Resolution: fixed
Status: assignedclosed

It's fixed in hrev24071

Note: See TracTickets for help on using tickets.