Opened 12 years ago

Closed 12 years ago

#1712 closed bug (fixed)

Can't boot since upgrade to Geforce 8600GT

Reported by: ekdahl Owned by: axeld
Priority: high Milestone: R1/alpha1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc: umccullough
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The computer booted fine with my built-in Geforce 6150, but since the upgrade Haiku won't even boot. Expected behaviour is that it should use the vesa driver (since 8xxx support is missing in nvidia driver) and still boot. I also added 2 GB more memory, but I doubt that is the problem. The upgrade was performed at the same time as Begeistert, so there is also a chance that the changes done then might have caused it.

Attachments (1)

output.JPG (247.7 KB) - added by ekdahl 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by ekdahl

Attachment: output.JPG added

comment:1 Changed 12 years ago by axeld

Component: Drivers/GraphicsDrivers/Graphics/nVidia
Milestone: R1R1/alpha
Priority: normalhigh

It looks like the responsible driver, but have you tried to remove it and see what happens then? Also, what device ID does your card have?

comment:2 Changed 12 years ago by ekdahl

Remove the driver or the card? If I select safe video mode in the boot menu, I get to the blue desktop. But it stops when the cursor is shown (the whole screen is blue except for the cursor). At this point the mouse used to lit up (maybe a USB problem when I get this far, using ohci).

I'm not sure how to check what ID the card has, but I'd guess it's 10de:0402 (http://pci-ids.ucw.cz/iii/?i=10de0402).

comment:3 Changed 12 years ago by ekdahl

Oh, I see now that the id is listed in the nvidia driver. Wonder if that is really tested.

comment:4 Changed 12 years ago by umccullough

Cc: umccullough added

If it helps clarify, I have never been able to properly get the nvidia driver working with my integrated GeForce 6100/6150 (I believe I have two separate motherboards, one with each of these chipsets).

In my case, it had always booted up to a black screen with BeOS, Zeta, and Haiku - and I was never sure if things were hung or not. Honestly, I think there were other issues preventing a proper boot of Haiku anyway on those machines at the time (back in 2006).

I admit I haven't tried booting in a long time with either of these boards (as they're currently being used for other purposes). Both have only analog VGA ports, no DVI.

If I get a chance, I will try to test them out again in the coming months.

comment:5 in reply to:  4 Changed 12 years ago by ekdahl

Replying to umccullough:

If it helps clarify, I have never been able to properly get the nvidia driver working with my integrated GeForce 6100/6150 (I believe I have two separate motherboards, one with each of these chipsets).

I've been testing Haiku with Geforce 6150 for a couple of months, and it's been working just fine with the nvidia driver.

I admit I haven't tried booting in a long time with either of these boards (as they're currently being used for other purposes). Both have only analog VGA ports, no DVI.

I have only tested with DVI.

comment:6 Changed 12 years ago by ekdahl

Removing the card id from the nvidia driver indeed makes it boot to the blue desktop at least (no mouse or tracker though).

comment:7 Changed 12 years ago by pieterpan

Rudolfc tried out the 8xxx cards with his driver by adding most of the device ids. When we tried my laptop with it (8600M), it appeared that it will require quite some work to get his driver to work with the 8xxx series. I guess he hasn't taken out the device ids yet. I have to select safe mode every time I boot. But I do get all the way with booting. Hope this helps Pieter

comment:8 Changed 12 years ago by aldeck

I remember it worked for me with hrev22412, with a 8800GTS, see #1361 (i should update that ticket btw :). I'm pretty sure it wasn't even in safe mode. I'd have to recheck, but i don't have access to this machine right now.

comment:9 Changed 12 years ago by aldeck

I looked at my log in ticket #1361, i was in vesa, my device id wasn't recognized. It wasn't stable due to another bug, but i had the desktop at least!

comment:10 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed

The nvidia driver no longer pretends to support devices it can't support. Fixed in hrev23579.

Note: See TracTickets for help on using tickets.