Opened 12 years ago

Closed 11 years ago

#1730 closed bug (fixed)

BMidiStore: GetEventTime error using ThemeTris game

Reported by: kvdman Owned by: korli
Priority: normal Milestone: R1
Component: Kits/Midi Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Im using ThemeTris,

http://www.haikuware.com/view-details/games/classics/1137-themetris

and get crashes when sounds are enabled in ThemeTris. See the attached screenshot please.

Attachments (3)

themetris.jpg (203.2 KB) - added by kvdman 12 years ago.
1.jpg (197.3 KB) - added by kvdman 12 years ago.
midi-error.jpg (116.3 KB) - added by kvdman 11 years ago.

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by kvdman

Attachment: themetris.jpg added

comment:1 Changed 12 years ago by korli

I can't find a download for ThemeTris. Please provide a link.

comment:2 Changed 12 years ago by kvdman

Hi,

the provided link above should work now. the website was down for a bit...

thx

comment:3 Changed 12 years ago by korli

Resolution: fixed
Status: newclosed

Fixed in hrev23940.

comment:4 Changed 12 years ago by kvdman

Resolution: fixed
Status: closedreopened

I'm not sure if it's related to the midikit or not, because the kdb isn't initiated, and locks the system when I start a game so I can't get a trace.

I thought I'd rather reopen this perhaps you can reproduce this hang?

comment:5 Changed 12 years ago by korli

Can you launch the game from a Terminal and see the output ?

Changed 12 years ago by kvdman

Attachment: 1.jpg added

comment:6 Changed 12 years ago by kvdman

Hi,

I can launch it from the terminal, but as soon as a new game is started, there's no further output; the system locks.

If you disable sounds & music, the game works, so it must be related to the midi/audio server. I realize this probably doesn't help much.

I've attached a pic when it hangs.

comment:7 Changed 11 years ago by korli

It seems there is a real time thread out of control. Going KDL and using unreal let the system back. Midi threads seem at fault here using a lot of CPU. Also offscreen rendering in app_server takes the remaining CPU.

comment:8 Changed 11 years ago by kvdman

This game won't lock the system anymore. Sounds play but they are the wave files. I don't think the midi kit works at all, does it? Some sound files in the theme directory are *mid and they won't play. I've tried playing them and other midi files in Haiku's midi player and sound play, and they play nothing; no sound.

comment:9 Changed 11 years ago by umccullough

IIRC, you also need to get a SoundFont archive to go with fluidsynth before you'll get any sound from the midi kit. Without any sound fonts, it has no instruments to use for playing the music :)

That's what I've heard anyway, they can be quite large, easily several MB for a small one - I haven't tried it myself.

I believe they're not distributed automatically due to size and licensing, but that's mostly just a hunch.

comment:10 Changed 11 years ago by kvdman

Ohhhh... Thanks for that tip Urias! I'll retry with some soundfonts, and look around and see if there are any generously licensed fonts.

comment:11 Changed 11 years ago by kvdman

I followed this tip here:

http://betips.net/1997/09/09/older-midi-apps-and-beos-5/

and the discussion here:

http://www.haiku-os.org/community/forum/softsynth_integrated_fluidsynth

Copying the library over from R5 and then linking it to big_synth, I then dropped a midi file from ThemeTris in the player. It was unable to play.

See the attached screenshot please.

Changed 11 years ago by kvdman

Attachment: midi-error.jpg added

comment:12 Changed 11 years ago by axeld

I'm closing this bug, as the MIDI problem is definitely a different issue.

Have you tried not using a symlink but rename Patches111.hsb directly to big_synth.sy? Also, have you tried different soundfont archives? I've never tried for myself, but IIRC it did work at some point in the past.

comment:13 Changed 11 years ago by axeld

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.