Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1731 closed bug (fixed)

unmounting partitions hangs

Reported by: stippi Owned by: axeld
Priority: high Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: andreasf
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • Mount a BFS partition in Tracker

(Right clicking this volume's icon has the usual popup menu.)

  • Unmount the partition

(The volume's icon will stay on the desktop, right-clicking it will show the folder popup menu.)

  • Try to invoke Tracker's mount menu -> Tracker will now hang.
  • Killing Tracker kills the complete team, but the windows will stay on screen. Looking at the kernel team shows a thread named Tracker.

More info: When mounting/unmounting a partition using DriveSetup, DriveSetup will hang at unmounting the same as Tracker. Killing it removes the team completely, but the windows stay on screen and there is a thread called DriveSetup in the kernel team. Trying to invoke the mount menu from Tracker results in Tracker hanging too.

Can't investigate further with kernel debugger atm, because of USB keyboard, but this is 100% reproducible for me.

Change History (5)

comment:1 Changed 11 years ago by axeld

I can't reproduce this, at least not using Qemu and a current build.

comment:2 Changed 11 years ago by andreasf

Cc: andreasf added

I've noticed this for some time on my machine: Unmounting does not work but no noticeable unmount problems when just shutting down or restarting. System is a P4 HT - maybe an SMP issue?

comment:3 Changed 11 years ago by axeld

Priority: normalhigh
Status: newassigned

I can reproduce this on real hardware; it's a bug in the slab allocator's depot implementation; it will deadlock on destruction (it only happens on SMP machines because there is no depot on uni-processor machines).

comment:4 Changed 11 years ago by axeld

Resolution: fixed
Status: assignedclosed

Fixed in hrev23825. I've disabled the CPU depots completely, though - but this code needs some work anyway.

comment:5 Changed 11 years ago by andreasf

Works for me in Tracker and DriveSetup. Thanks!

Note: See TracTickets for help on using tickets.