Opened 11 years ago

Closed 8 years ago

#1744 closed bug (duplicate)

Amilo A7640W: Network doesn't work (sis900)

Reported by: jackburton Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/pre-alpha1
Keywords: Cc: andreasf
Blocked By: #4968 Blocking:
Has a Patch: no Platform: x86

Description

Network doesn't work correctly with this computer. It uses Axel's sis900 driver, but I can't seem to ping anything. And sometimes configuring the interface fails too. I can provide debug output or whatever else you need.

Change History (21)

comment:1 Changed 11 years ago by jackburton

Enabled debug, and found out that it doesn't find the PHY MII interface (at least, it doesn't print the line: Found MII PHY.

comment:2 Changed 11 years ago by axeld

You might want to have a look at the Linux version of that driver to see what PHY MII is found there.

comment:3 Changed 11 years ago by andreasf

I'm running on a Scaleo 600 GA-8SGXP with sis900 and it works in static mode, DHCP doesn't.

comment:4 Changed 11 years ago by andreasf

Cc: andreasf added

comment:5 Changed 11 years ago by axeld

That could be a similar problem - having no MII to talk to should usually make DHCP impossible, but usually also causes more problems than that.

comment:6 Changed 11 years ago by umccullough

Any chance of porting if_sis from FBSD?

I assume is has equal or better support for hardware - I know it has more than just sis900, including dp83815 (natsemi and netgear cards) which would eliminate the need for a separate dp83815 driver as well.

On the other hand, perhaps the Haiku sis900 driver has more features?

comment:7 Changed 11 years ago by vzsolt

I don't know much about the Haiku driver, but I know that FreeBSD's driver works fine even with DHCP on my Acer notebook with a sis900 NIC.

comment:8 Changed 11 years ago by axeld

Since drivers using the FreeBSD layer are not as efficient as native drivers are for now (we might be able to change that in the future), I would rather like to extend the existing SiS 900 driver to support your hardware.

comment:9 in reply to:  2 Changed 11 years ago by jackburton

Owner: changed from axeld to jackburton

Replying to axeld:

You might want to have a look at the Linux version of that driver to see what PHY MII is found there.

Ok, I think I can handle this on my own.

comment:10 Changed 11 years ago by jackburton

Status: newassigned

comment:11 Changed 11 years ago by jackburton

Actually I was wrong:

  1. The MII is actually recognized (Realtek) but I can't see it inside the syslog. Enabling the console boot logging, though, showed it's initialized correctly and working.
  2. Network doesn't work reliably for me under vmware either. I just got lucky (twice) when I tested it before filing this ticket: worked under vmware all the times, never under real hardware.

So I don't think the problem is related to the sis900 driver, but more to the network stack in general.

comment:12 Changed 11 years ago by axeld

Your version of the SiS 900 chip might need some workaround. At least it sounds unlikely that it is much more unreliable than the same stack with other cards (and it works pretty well over here with a variety of cards).

comment:13 in reply to:  12 ; Changed 11 years ago by jackburton

Replying to axeld:

Your version of the SiS 900 chip might need some workaround. At least it sounds unlikely that it is much more unreliable than the same stack with other cards (and it works pretty well over here with a variety of cards).

I don't know... I had a deep look at the linux and openbsd drivers, and it seems all the needed workarounds have been applied in your driver. Could this be related to bug #1853 ?

comment:14 Changed 11 years ago by euan

I have the same problem on my laptop with the sis900. I've already tried a port of the freebsd driver and it couldn't find the MII. I can post a diff tomorrow of the changes. I couldn't figure out what the issue is.

Co-coincidently the same issue occurs with the Realtek 8139 driver (interface appears up but routing table looks odd).

I also ported the Marvell Yukon 'sk' driver and it too can't find the MII, frustratingly. The ipro100 does work however on my old compaq p2 machine. :)

comment:15 in reply to:  13 Changed 11 years ago by axeld

Replying to jackburton:

I don't know... I had a deep look at the linux and openbsd drivers, and it seems all the needed workarounds have been applied in your driver. Could this be related to bug #1853 ?

I don't see an obvious connection, at least :-) I'm using Haiku under VMware (ipro1000), as well as on real hardware (different chipsets), and it just works nicely over here.

Replying to euan:

I also ported the Marvell Yukon 'sk' driver and it too can't find the MII, frustratingly. The ipro100 does work however on my old compaq p2 machine. :)

The FreeBSD layer might very well still have some issues. The ipro1000 driver contains its own MII code, so that makes it different from others. Dunno about the ipro100 driver ATM, though.

comment:16 Changed 11 years ago by jackburton

I see lots of "RX underrun" interrupts in the syslog, but nothing else.

Is it possible that this problem is caused by too many devices sharing the same interrupt ? The NIC is on irq line 5, just like the audio card, the 4-in-1 card reader, and the usb controller. On linux this card is on IRQ line 18, and doesnt' share IRQs with any other device.

comment:17 Changed 11 years ago by axeld

This is possible if there is a driver that doesn't play well in this case. But you can easily prove that theory by removing the drivers of those other devices - if the driver then works nicely, we can look further :-)

comment:18 in reply to:  17 Changed 11 years ago by jackburton

Replying to axeld:

This is possible if there is a driver that doesn't play well in this case. But you can easily prove that theory by removing the drivers of those other devices - if the driver then works nicely, we can look further :-)

I removed the usb drivers and the auich driver, but nothing changed.

comment:19 Changed 10 years ago by jackburton

Owner: changed from jackburton to nobody
Status: assignednew

I don't have that laptop anymore.

comment:20 Changed 9 years ago by stargatefan

same issue in ticket 6640 and I am willing to send the motherboard and cpu to a dev with ram for testing if need be. This affects alot of p4 and 1.0-2.0 ghz amd machine with sis 900 network chips.

comment:21 Changed 8 years ago by jackburton

Blocked By: 4968 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.