Opened 10 years ago

Closed 9 months ago

#4968 closed bug (fixed)

Unable to Connect to the Internet with sis900

Reported by: Sanandreas Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/sis900 Version: R1/alpha1
Keywords: Cc: planche2k@…, siarzhuk
Blocked By: Blocking: #1744, #6640
Has a Patch: no Platform: All

Description

Hi to all, i've a problem with sis900. I can ping the loopback interface (127.0.0.1) but I am not able to ping gateway (error message "no route to host) or to connect to the Internet. If i try an Ip that no match my local network i receive Network is unreachable Ip settings e route table is ok. In attachment i posted ifconfig, route table and syslog. Thanks

Attachments (2)

syslog.txt (252.5 KB ) - added by Sanandreas 10 years ago.
syslog.2.txt (95.5 KB ) - added by stargatefan 8 years ago.

Download all attachments as: .zip

Change History (20)

by Sanandreas, 10 years ago

Attachment: syslog.txt added

comment:1 by jackburton, 10 years ago

Could this be a dup of #1744 ?

comment:2 by andreasf, 10 years ago

Cc: planche2k@… added

comment:3 by tonestone57, 10 years ago

Component: Network & InternetDrivers/Network/sis900
Owner: changed from nobody to axeld

Looking at your syslog I noticed:

KERN: Found MII PHY: Realtek RTL8201 PHY

Just a guess here but cause of your issue could be related to this:

http://haiku.it.su.se:8180/source/xref/src/add-ons/kernel/drivers/network/sis900/sis900.c#492

comment:4 by jackburton, 10 years ago

Thought that too, but that workaround is already in our sis900 driver.

comment:5 by tonestone57, 10 years ago

Try with static ip because I also noticed this in your syslog:

DAEMON 'DHCP': DHCP for /dev/net/sis900/0, status: Operation timed out

DAEMON 'DHCP': DHCP for /dev/net/sis900/0, status: General system error

sis900 driver appears to have loaded in syslog but can you check under /dev/net & list folders & files to confirm?

comment:6 by siarzhuk, 10 years ago

Cc: siarzhuk added

comment:7 by siarzhuk, 10 years ago

2 Sanandreas: Is it possible to configure this interface with static settings?

Please configure it to static, reboot and do the following test:
1) start the following command:

tcpdump -vvXXe -s 0 -i /dev/net/sis900/0 > dhcp-dump.txt


2) Go to "Preferences -> Network" and switch to DHCP. Press "Apply" button.
4) Please wait about 30 seconds than stop with Ctrl-C the tcpdump started at step 1).
5) Please attach the received dhcp-dump.txt to this ticket.

comment:8 by Sanandreas, 10 years ago

I have already try to use static configuration but the result is the same.

comment:9 by jackburton, 9 years ago

I have the same problem on a pc where the same driver worked flawlessy under beos R5. I tried to do a network capturing using wireshark and no ethernet packet comes out of the Network card.

comment:10 by jackburton, 9 years ago

Blocking: 1744 added

comment:11 by stargatefan, 8 years ago

This is still broken even with IOAPIC working. Would be nice for alpha3. I am willing to put in the work on the testing side for any dev interested in getting this ticket resolved.

I attached my syslog.2.txt

If there is anything anyone working on this bug needs, lt me know I will get it.

Last edited 8 years ago by stargatefan (previous) (diff)

comment:12 by luroh, 8 years ago

Blocking: 6640 added

(In #6640) Right, thanks.

by stargatefan, 8 years ago

Attachment: syslog.2.txt added

comment:13 by luroh, 8 years ago

Possible dupe in #5086, slightly different hardware revision.

comment:14 by tonestone57, 8 years ago

Issue with syslog.2.txt (sis900 rev.90) is MAC is not found:

1406	KERN: sis900: could not get MAC address
1407	KERN: Found MII PHY: Realtek RTL8201 PHY

The sis900 requires using different methods to get the MAC depending on the revision #.
http://tomoyo.sourceforge.jp/cgi-bin/lxr/source/drivers/net/sis900.c#L511 http://vcomtech.net/vmwarexr/source/linux/drivers/net/sis900.c#L372

Haiku's for comparison:
http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/network/sis900/sis900.c#L579

Also missing couple of PHYs.
http://tomoyo.sourceforge.jp/cgi-bin/lxr/source/drivers/net/sis900.c#L129

For syslog.txt (sis900 rev.91):
The MAC is found but DHCP times out. Different issue. DHCP issue is tougher to track down the cause. Also, fixing MAC issue for 2nd syslog may still run into issue from 1st syslog (DHCP timing out).

A developer either has to compare Haiku sis900 driver to BSD's and update it or just switch over to the BSD version of sis900. Going to BSD sis900 driver would be good and easy solution to get this working and if a developer ever updates Haiku's sis900 could just switch back to it.

@Sanandreas, can you retest with newer nightly image to see if DHCP issue still happening? To rule out any other change from having fixed this.
http://www.haiku-files.org

comment:15 by phoudoin, 8 years ago

With a broken driver or without a valid MAC address, in any case DHCP negotiation can't work for obvious reason.

All these hints lead indeed to think the current sis900 don't support your card as it should.

comment:16 by stargatefan, 8 years ago

any pointers or guides to porting a bsd driver ? I'll give it a whirl.

Last edited 8 years ago by stargatefan (previous) (diff)

comment:17 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:18 by waddlesplash, 9 months ago

Resolution: fixed
Status: assignedclosed

Probably fixed by switching to the FreeBSD driver in hrev52675.

Note: See TracTickets for help on using tickets.