Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1759 closed bug (fixed)

Scroll Increments in Terminal Suboptimal

Reported by: bonefish Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc: andreasf
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev23895. Real hardware and VMware.

Scrolling by mouse wheel or by scroll bar arrows scrolls only by one pixel per step/click. Clicking the scroll bar (above or below the handle) scrolls only by about half a line. The better increments would be one complete line and one complete page (maybe minus one line) respectively.

Change History (7)

comment:1 Changed 11 years ago by andreasf

Cc: andreasf added

comment:2 Changed 11 years ago by jackburton

Status: newassigned

comment:3 Changed 11 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev23913

comment:4 Changed 11 years ago by bonefish

Works better now. The page-wise scrolling increment should be adjusted when the window size is changed, though.

comment:5 in reply to:  4 ; Changed 11 years ago by jackburton

Replying to bonefish:

Works better now. The page-wise scrolling increment should be adjusted when the window size is changed, though.

That should be done in hrev23914.

comment:6 in reply to:  5 Changed 11 years ago by bonefish

Replying to jackburton:

Replying to bonefish:

Works better now. The page-wise scrolling increment should be adjusted when the window size is changed, though.

That should be done in hrev23914.

Sorry, I should have made that clearer: I tested with hrev23921 and just retested with hrev23930. It doesn't work. Can be easily seen, if you do a "seq 100" and play with the Terminal window size. It always scrolls by the initial size.

comment:7 Changed 11 years ago by jackburton

Yeah you're right. I moved the call to SetSteps() to FrameResized(), so it's called also when the window is resized. I tested as you suggested and it looks okay now (except for other weird bugs like missing invalidation, wrong view repositioning and stuff like that, not caused by my changes) but I'll fix them later.

Note: See TracTickets for help on using tickets.