#17601 closed bug (no change required)

R1/beta3 32-bit won't boot

Reported by: KantosKan Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/beta3
Keywords: Cc: KantosKan
Blocked By: Blocking:
Platform: All

Description

I reformatted a partition, and re-installed R1/beta2, on my HP 12-core opteron computer. It boots, and runs reasonably well. Then I upgraded to R1/beta3. It now will not boot. It freezes on the launch icon of the boot sequence. When I reboot into another partition, it shows no disk space left on the existing 32-bit partition. Previously there was more than 100MB free. The disk was completely filled while trying to launch.

listdev output and syslog output attached. I also have pictures of the on-screen debugging while booting, if needed.

Attachments (10)

listdev (3.6 KB ) - added by KantosKan 12 months ago.
listdev output
syslog (298.5 KB ) - added by KantosKan 12 months ago.
syslog file after the attempt to boot
IMG_1277.JPG (2.5 MB ) - added by KantosKan 12 months ago.
backtrace
IMG_1279.JPG (3.2 MB ) - added by KantosKan 12 months ago.
IMG_1280.JPG (3.3 MB ) - added by KantosKan 12 months ago.
IMG_1281.JPG (2.4 MB ) - added by KantosKan 12 months ago.
IMG_1282.JPG (2.2 MB ) - added by KantosKan 12 months ago.
IMG_1283.JPG (2.4 MB ) - added by KantosKan 12 months ago.
IMG_1284.JPG (3.1 MB ) - added by KantosKan 12 months ago.
IMG_1285.JPG (2.5 MB ) - added by KantosKan 12 months ago.

Change History (24)

by KantosKan, 12 months ago

Attachment: listdev added

listdev output

by KantosKan, 12 months ago

Attachment: syslog added

syslog file after the attempt to boot

comment:1 by waddlesplash, 12 months ago

Please try the very latest nightly build and see what happens.

comment:2 by KantosKan, 12 months ago

OK, I installed hrev 55895, 32-bits. When I tried to boot, it stalled with a white screen after the launch icon. Then I tried again with safe mode, and safe graphics mode. It stalled with a white screen, with some text:

debugger for team 488 on interface local (shredder) created and initialized successfully [thread stopped 488 sh] current thread 488 "sh" debugger>drawfmanager::File::Load("boot/system/bin/bash"): no .debug_info or .debugabbrev debugger>drawfmanager::File::Load("boot/system/runtime_loader"): no .debug_info or .debugabbrev debugger>drawfmanager::File::Load("boot/system/runtime_loader"): no .debug_info or .debugabbrev debugger>drawfmanager::File::Load("boot/system/lib/libncurses.so.6.2.0"): no .debug_info or .debugabbrev debugger>drawfmanager::File::Load("boot/system/lib/libncurses.so.6.2.0"): no .debug_info or .debugabbrev

comment:3 by waddlesplash, 12 months ago

Please type "bt" at the prompt, take a picture, and upload it here.

by KantosKan, 12 months ago

Attachment: IMG_1277.JPG added

backtrace

comment:4 by KantosKan, 12 months ago

OK, picture attached. It behaved differently on this boot, likely because the first attempt to boot caused the file system on the disk to be nearly completely filled. Image uploaded is IMG_1277.jpg

comment:5 by diver, 12 months ago

The kernel panic related to bfs driver on this photo is being tracked in #6781.

Can you reproduce the white screen debugger (after the launch icon) and type bt there?

comment:6 by diver, 12 months ago

BTW you should be able to exit KDL by typing es.

by KantosKan, 12 months ago

Attachment: IMG_1279.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1280.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1281.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1282.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1283.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1284.JPG added

by KantosKan, 12 months ago

Attachment: IMG_1285.JPG added

comment:7 by KantosKan, 12 months ago

img_1279: trying to boot into hrev55895 from the hard disk
img_1280: same, after bt
img_1281: trying to boot using safe mode and safe graphics mode
img_1282: showing the free space on the installation volume, immediately after mounting it while booted from usb stick, after re-installing hrev55895
img_1283: suddenly the disk is full, a few seconds after mounting it
img_1284: the installer crashes, while trying to install on the filled-up disk
img_1285: after mounting the hard disk after rebooting from the usb stick after the installer crash.

it is puzzling that it always is able to boot from the usb stick, but not from the hard disk after installing the same os.

Last edited 12 months ago by diver (previous) (diff)

comment:8 by diver, 12 months ago

app_server crashed in freetype code, do you maybe have some custom fonts installed? Does the crash goes away of you remove them?

comment:9 by diver, 12 months ago

Can you check where did the free space go? Check with DiskUsage.

comment:10 by KantosKan, 12 months ago

There are no custom fonts. It is a new installation after formatting the partition. Right now I can't find out where the free space went, because I reformatted the disk and trying installing hrev 55895 again. It installed successfully, but when booting, there was a white screen that lasted several minutes, then it finally booted into the desktop. It runs very slowly, starting Terminal can take 30 seconds or several minutes. Right-clicking on a folder can take 30 seconds or more before the file list shows up.

comment:11 by diver, 12 months ago

Can you check if some process is using the cpu? Are you sure there is no problem with your hard drive?

comment:12 by diver, 12 months ago

Run tail -F /var/log/syslog and see if there is anything suspicious.

comment:13 by KantosKan, 12 months ago

Thanks for this suggestion. I tried installing R1/beta3 32bits on a different hard drive, and it works ! So it appears that the problem is with the hard drive, not the OS. I apologize for all the trouble, and really appreciate all your help.

comment:14 by diver, 12 months ago

Resolution: no change required
Status: newclosed

Great! It could be helpful if Haiku could detect this somehow and inform a user about storage problems if it manages to boot to the Desktop.

Closing.

Note: See TracTickets for help on using tickets.