Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#181 closed bug (fixed)

Menu windows steal the focus and never give it back

Reported by: jackburton Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

To reproduce:

  • Start tracker
  • Click on the "window" menu, select "settings"
  • Enable single window browsing and navigator
  • Close the settings window
  • Now try to click on any navigator button or on the address bar: it won't work,

it seems those views never get focus anymore. Closing and reopening the window fixes the problem.

  1. Menu windows shouldn't steal the focus
  2. At least they should give focus back when they are closed.

This replaces #159

Change History (26)

comment:1 Changed 13 years ago by axeld

Status: newassigned

comment:2 Changed 13 years ago by axeld

I can reproduce that the navigator items don't work after this procedure, and I'll look into that. I don't see any menus stealing focus, though - do you have any local changes that could be causing this?

comment:3 Changed 13 years ago by jackburton

stefano@shiryu:~/haiku/haiku$ svn status ? src/tools/jam ? src/tests/kits/interface/PictureTest.cpp ? src/tests/kits/game/windowscreen_test ? headers/private/interface/ClipRegion.h

Not anything related, at least. I'll try some way to reproduce it.

comment:4 Changed 13 years ago by axeld

Resolution: fixed

comment:5 Changed 13 years ago by axeld

Status: assignedclosed

comment:6 Changed 13 years ago by axeld

The tracker problem is gone with hrev16442. Please check again if you can reproduce the menus stealing focus - otherwise I'll close this bug.

comment:7 Changed 13 years ago by jackburton

Resolution: fixed

comment:8 Changed 13 years ago by jackburton

menus stealing focus: I can reproduce it this way: Start haiku, click on the deskbar so that it gets the focus and steals from the terminal.

Then click on the terminal again Then click on the terminal menu.

comment:9 Changed 13 years ago by jackburton

Status: closedreopened

comment:10 Changed 13 years ago by axeld

Status: reopenedassigned

comment:11 Changed 13 years ago by axeld

Great, I can easily reproduce this bug now, thanks!

comment:12 Changed 13 years ago by jackburton

Cc: diver added

comment:13 Changed 13 years ago by jackburton

* Bug 229 has been marked as a duplicate of this bug. *

comment:14 Changed 13 years ago by axeld

Fixed in hrev16532.

comment:15 Changed 13 years ago by axeld

Resolution: fixed

comment:16 Changed 13 years ago by axeld

Status: assignedclosed

comment:17 Changed 13 years ago by jackburton

Bug shows up again. Reopening...

comment:18 Changed 13 years ago by jackburton

Resolution: fixed

comment:19 Changed 13 years ago by jackburton

Status: closedreopened

comment:20 Changed 13 years ago by axeld

Could you elaborate a bit more? I definitely can't reproduce it anymore, at least not with the method you proposed.

comment:21 Changed 13 years ago by jackburton

I can reproduce it sometimes, but can't find a way to do it consistently this time.

comment:22 Changed 13 years ago by axeld

This has probably been fixed with hrev16811. Can you still reproduce it? Otherwise, I'd like to close this bug for good now :)

comment:23 Changed 13 years ago by jackburton

Resolution: fixed

comment:24 Changed 13 years ago by jackburton

Status: reopenedclosed

comment:25 Changed 13 years ago by jackburton

Fixed (hopefully for good) in hrev16811 :)

comment:26 Changed 13 years ago by wkornewald

Description: modified (diff)
Platform: All
Note: See TracTickets for help on using tickets.