Opened 11 years ago

Closed 11 years ago

#1838 closed bug (fixed)

Horizontal scrolling is broken in BColumnListView.

Reported by: stippi Owned by: anevilyak
Priority: normal Milestone: R1/alpha1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Additionally, the scroll area is not updated properly when removing items it seems.

Change History (13)

comment:1 Changed 11 years ago by anevilyak

Hi stippi,

Want me to take over this one? I have some experience with the BCLV code so I'd be willing. Also, which scroll area are you referring to? Horizontal or Vertical?

comment:2 Changed 11 years ago by stippi

Owner: changed from stippi to anevilyak

Oh yes, please do! Vertical scrolling seems to work fine. But horizontal scrolling does not affect the header view.

comment:3 Changed 11 years ago by anevilyak

Status: newassigned

Will look, do you have any good app for a testcase illustrating this or will I need to write one?

comment:4 Changed 11 years ago by stippi

DriveSetup can be used to reproduce it. It also builds in the test environment, in case you want to use that.

comment:5 Changed 11 years ago by humdinger

This should be the same bug: ticket #1252

comment:6 Changed 11 years ago by anevilyak

Actually, no. BeShare uses the column list view from Santa's Gift Bag, which has nothing in common code-wise with BColumnListView.

comment:7 Changed 11 years ago by anevilyak

Hi stippi,

One thing that strikes me as immediately odd is that the ScrollTo hooks don't seem to be getting called....at least the printfs in said hooks aren't showing up at all.

comment:8 Changed 11 years ago by stippi

Doh... just change BScrollBar::ValueChanged() to call ScrollTo() instead of ScrollBy(). That should do it. :-)

comment:9 Changed 11 years ago by stippi

Thanks for tracking this one down, Rene!

comment:10 Changed 11 years ago by stippi

I feel very stupid now, because I was looking at BScrollBar::ValueChanged() _very_ often. :-)

comment:11 Changed 11 years ago by anevilyak

If that's the case, shouldn't we modify BView::ScrollBy so it just wraps a call to the virtual version? AFAIK the virtual hook should be called in all cases, otherwise the app can't always get correct behavior, since ScrollBy is not overrideable. Replacing ScrollBy with ScrollTo in ValueChanged does indeed make BCLV behave correctly here btw.

comment:12 Changed 11 years ago by anevilyak

Also, this would seem to imply that it is indeed also the cause of ticket #1252, though I'll need to test if that one behaves correctly with that change.

comment:13 Changed 11 years ago by anevilyak

Resolution: fixed
Status: assignedclosed

Fixed in hrev25559.

Note: See TracTickets for help on using tickets.