Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1862 closed bug (fixed)

App server crash

Reported by: jackburton Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

App server crashed when doing the following:

  1. Start StyledEdit, open /boot/beos/etc/KanBe/default/.canna.
  2. Edit -> Select All
  3. Font -> Konatu Regular

It's always reproducible

Attachments (1)

crash.PNG (32.8 KB) - added by jackburton 11 years ago.
app server crash

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by jackburton

Attachment: crash.PNG added

app server crash

comment:1 Changed 11 years ago by axeld

Status: newassigned

comment:2 Changed 11 years ago by axeld

Resolution: fixed
Status: assignedclosed

Fixed in hrev24160. Could originate in a bug in StyledEdit/STXT/libbe.so or .canna contains invalid characters - we probably should investigate this a bit more.

comment:3 Changed 11 years ago by jackburton

Ok I'll have a look to the StyledEdit/TextView part of code. Thanks for the quick fix.

comment:4 Changed 11 years ago by axeld

Looks like .canna and UTF8CountBytes() is to blame: the former obviously contains a malformed UTF-8 character, and the latter reported a 4 byte character (which got divided into 2 characters in the app_server again).

I've changed UTF8CountBytes() so that it will now count 2 characters - one malformed, and one okay.

comment:5 Changed 11 years ago by jackburton

Looks like you were faster :) Thank you again!

Note: See TracTickets for help on using tickets.