Opened 12 years ago

Closed 11 years ago

#1869 closed enhancement (fixed)

Mediaplayer errors out instead of displaying a dialog box explaining missing codec

Reported by: scottmc Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I found a set of 10 encoded video files on codectest.com, I unzipped these and tried playing each one in Haiku and none of them played correctly, some of them crashing mediaplayer, others playing only grabled sound and/or video. I then tried doing the same in my BeOS Max install and most also failed there, only the sorensen2cbr played right. But in BeOS the media player would display a message to the user saying that a codec (plugin/translator?) was needed, blah blah blah, check be.com. It might be good to put together move video files like the set on codectest.com to test codecs that are already suported in Haiku. I did also try vlc0.8.6 on Haiku and many of the videos played just fine, but we've come to expect that from vlc.

Change History (4)

comment:1 by marcusoverhagen, 12 years ago

Type: bugenhancement

comment:2 by diver, 11 years ago

Component: Audio & Video/CodecsApplications/MediaPlayer

comment:3 by scottmc, 11 years ago

This seems to be fixed, just need to close out the ticket. I tried playing an unsupported video on hrev26990 and it gave me a dialog box warning about a missing codec, instead of dropping me to a debug dialog box.

comment:4 by mmlr, 11 years ago

Resolution: fixed
Status: newclosed

Closing as requested.

Note: See TracTickets for help on using tickets.