Opened 11 years ago

Closed 10 years ago

#1908 closed bug (duplicate)

page_fault in network stack (using Firefox)

Reported by: stippi Owned by: axeld
Priority: critical Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc: tqh
Blocked By: #2029 Blocking:
Has a Patch: no Platform: All

Description

I just booted Haiku and launched Firefox without much delay. Next thing I know, I was in KDL:

...
<kernel> page_fault_exception
<kernel> int_bottom

iframe...

<kernel> list_remove_link
<kernel> list_remove_head_item
</boot/.../netstack> delete_children
</boot/.../netstack> socket_delete
</boot/.../netstack> socket_free
</boot/.../netstack> net_stack_free_cookie
<kernel> devfs_free_cookie
<kernel> file_free_fd
<kernel> put_fd
<kernel> common_close
<kernel> _user_close
<kernel> pre_syscall_debug_done

iframe...

<libnetwork.so> closesocket

Change History (4)

comment:1 in reply to:  description Changed 11 years ago by franxico

Replying to stippi:

I just booted Haiku and launched Firefox without much delay. Next thing I know, I was in KDL:

Just dit that a couple of times with VMWare, hrev25562, FF 2.0.0.12, with no problems at all.

comment:2 Changed 11 years ago by tqh

Cc: tqh added

comment:3 Changed 10 years ago by Adek336

Also note #2029.

comment:4 Changed 10 years ago by axeld

Blocked By: 2029 added
Resolution: duplicate
Status: newclosed

Duplicate of #2029 which has better info.

Note: See TracTickets for help on using tickets.