Opened 11 years ago

Closed 10 years ago

#2029 closed bug (fixed)

KDL (page fault) in network stack linked list code when quitting Firefox (closing socket)

Reported by: stippi Owned by: axeld
Priority: critical Milestone: R1
Component: Network & Internet/TCP Version: R1/pre-alpha1
Keywords: Cc: tqh
Blocked By: Blocking: #1908
Has a Patch: no Platform: All

Description

I ran into my issue with Firefox not connecting anymore and wanted to quit it. The system had been running for quite a while with lots of activity. Vision was running at the time of the crash, I had used various aspects of networking during the session. Attached are photos of the KDL stack trace.

Attachments (3)

net_stack_KDL1b.jpg (146.8 KB) - added by stippi 11 years ago.
net_stack_KDL2b.jpg (150.2 KB) - added by stippi 11 years ago.
net_stack_KDL3b.jpg (132.1 KB) - added by stippi 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by stippi

Attachment: net_stack_KDL1b.jpg added

Changed 11 years ago by stippi

Attachment: net_stack_KDL2b.jpg added

Changed 11 years ago by stippi

Attachment: net_stack_KDL3b.jpg added

comment:1 Changed 11 years ago by tqh

Cc: tqh added

comment:2 Changed 11 years ago by kaliber

Maybe it's related to the bug #2189?

comment:3 Changed 11 years ago by tqh

Two of the screenshots go thru socketpair functions in Mozilla code, and that code could be non existant, untested, plain wrong and so on. Need to check the state and how/when it gets built. IIRC it should return PR_NOT_IMPLEMENTED.

comment:4 Changed 10 years ago by Adek336

Also note #1908.

comment:5 Changed 10 years ago by axeld

Blocking: 1908 added

(In #1908) Duplicate of #2029 which has better info.

comment:6 Changed 10 years ago by stippi

I have never seen this again in recent times, it may have been fixed by the recent fixes to the TCP buffer management. Note that #2197 is marked as a possible duplicate of this ticket, but was already in the R1/alpha milestone. I would also be fine with marking both tickets as fixed.

comment:7 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

If not already fixed, it has been in hrev30363.

Note: See TracTickets for help on using tickets.