Opened 12 years ago

Closed 8 years ago

#1923 closed bug (invalid)

Time Date inaccurate after booting up Haiku

Reported by: cebif Owned by: axeld
Priority: low Milestone: R1
Component: Preferences/Time & Date Version: R1/pre-alpha1
Keywords: Cc: andreasf, olive@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After booting up Haiku the Time and Date has changed. I have to reset it correctly. For example after my last boot the time was 11:04 AM and the Date was 15th March when it should have been 12:04 PM and 16th March, New Zealand time. I am not certain how to reproduce this but it is either caused after having a long session in one of my other operating systems or booting from cold. My other operating systems are Ubuntu 7.10 and BeOSR5.05 Bone. On booting into R5.05 Bone I frequently find exactly the same bug. I don't know if R5.05 Bone is causing the problem in Haiku or the other way around or they both have the same bug. I will do some more testing, by not booting into one of them for a sufficient period and see if the problem occurs in one or both of them. Also I will not mount the other while I have one in session. Sometime I find even Ubuntu 7.10 time has become inaccurate but a lot less than Haiku or BeOS5.05 Bone. The time setting in my BIOS is set at 24 hour GMT +12 hours. It is always accurate. I was testing with hrev24393.

Change History (13)

comment:1 by scottmc, 12 years ago

Do you recall what day and time this happened? Try setting your date and time back to that same time and see if it's a repeatable thing that is tied to a specific date/time. Almost sounds like a daylight saving time issue.

comment:2 by cebif, 12 years ago

I just did a cold boot into Haiku after the computer been turned off for 3 hours. The time was out by 13 hours it was 4:20 AM when it should have been 5:20 PM. It looks like the bug is in Haiku and not Ubuntu 7.10 or another operating system putting the Haiku time settings out. I am not certain about why the BeOSR5.05 Bone time is out though. If one operating system affects another through the BIOS I don't know but it is out by about the same too. The BIOS time always seems to be correct but that is after I have corrected the operating system time and then rebooted into the BIOS setup. Next time when the time is out I wont correct it then reboot straight into BIOS setup.

in reply to:  1 comment:3 by cebif, 12 years ago

Replying to scottmc:

Do you recall what day and time this happened? Try setting your date and time back to that same time and see if it's a repeatable thing that is tied to a specific date/time. Almost sounds like a daylight saving time issue.

I cannot remember when it first happened. I think it was after I deleted Windows XP and put Ubuntu 7.10, about the beginning of February. There is still daylight saving time here in New Zealand until about the 22nd March. I recently had the wrong BIOS settings for a CPU and the computer would not boot. Not even to a error beep, so I had to reset it. When I set the BIOS time I set it one hour less than the actual time because of thinking it was only in the operating system that daylight savings was accounted for. Now when I look in the BIOS the time matches the operating system time. So does the BIOS time stay the same or does it have to change with daylight saving as well?

comment:4 by axeld, 12 years ago

Priority: normallow

Haiku currently uses MET and local time by default. Since you live in NZ, the time being off is just natural since you are also using Ubuntu which defaults to GMT.

If you'd be using Windows, you wouldn't see a difference. While I am personally in favour of using GMT myself, probably most people are actually using Windows, and would then have exactly your problem. We had spoken about this on the mailing list some time ago, but we didn't come to any conclusion yet.

comment:5 by andreasf, 12 years ago

Cc: andreasf added

Axel,

I have been facing this issue too in a triple-boot configuration with Ubuntu, BeOS and Haiku. In BeOS the time looked good but is off in Haiku, leading to issues when accessing a common BFS volume, i.e. for make (as mentioned recently on the list).

The natural way to fix this would be to offer a choice of storing as local or GMT, like Linux did until recently. It should default to GMT and offer local time for Windows compatibility only. But currently it seems that only displaying GMT time is possible.

A workaround might be to add NTP support to Haiku so that at least the time is adjusted to displaying and using the correct time even if storing it in different ways?

comment:6 by stippi, 12 years ago

I am affected by this too. I think it should be "low" priority, but I don't have time to look into it myself right now... ;-)

in reply to:  4 comment:7 by cebif, 12 years ago

Replying to axeld:

Haiku currently uses MET and local time by default. Since you live in NZ, the time being off is just natural since you are also using Ubuntu which defaults to GMT.

If you'd be using Windows, you wouldn't see a difference. While I am personally in favour of using GMT myself, probably most people are actually using Windows, and would then have exactly your problem. We had spoken about this on the mailing list some time ago, but we didn't come to any conclusion yet.

I have set opened the Time preferences on the Deskbar and put the "Clock set to" at GMT then adjusted to correct time. This set the BIOS time back 13 hours which is correct for GMT. I then rebooted into Ubuntu and the back into Haiku and the Time was correct. This might be a workaround by having Haiku set at GMT.

comment:8 by andreasf, 11 years ago

I don't remember seeing recent commits in this area, so what seemed to do the trick for me was to set the timezone in UserBuildConfig (Europe/Paris in my case). Haiku's clock is off by two hours then, as before. But if I choose GMT in Haiku's time settings, I get the correct time now. Five months ago, choosing that option changed it to something odd.

Is there a settings file or Jam rule to automate setting the display to GMT? In QEMU using -localtime is an easy option, but on a real machine the clock offset can easily get one's biorhythm shifted...

comment:9 by anevilyak, 11 years ago

That's determined by ~/config/settings/RTC_time_settings as on R5. Writing the value 'gmt' to that file suffices. It's one of several things I include in a zip full of pre-configured settings files I have in my UserBuildConfig.

in reply to:  9 comment:10 by andreasf, 11 years ago

Thanks, that works great! I suggest we document this in UserBuildConfig.ReadMe.

Even better would be if we could have a Jam rule to write that value into the file so that the user does not need to be instructed how to create the file and then to have it added (e.g., SetHaikuImageToUseGMT ;).

comment:11 by karmak, 11 years ago

Cc: olive@… added

comment:12 by Disreali, 9 years ago

Two years since last activity. Is this still valid?

comment:13 by leavengood, 8 years ago

Resolution: invalid
Status: newclosed

I am evaluating Time tickets due to the recent changes to Time by Hamish Morrison which I committed.

I don't think this is valid anymore, for several reasons.

Firstly this is really a difficult problem to solve in a general way because it depends on what other operating systems are installed on the machine. Haiku has a setting to use local or GMT time which is about the best it can do. More people use Windows so local time is a better default.

Secondly now that NTP is built into Time you can at least be sure that Haiku will have the right time after booting :)

Especially after my adding the NTP updating to the Bootscript in hrev41956.

So I'm closing this.

Note: See TracTickets for help on using tickets.