Opened 11 years ago

Closed 11 years ago

#1934 closed bug (fixed)

tcpdump is broken.

Reported by: bga Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Running tcpdump with any options results in it printint a line like this:

tcpdump:

After that, it exists immediately.

Change History (5)

comment:1 Changed 11 years ago by axeld

Priority: normallow

You're supposed to call it using the '-i' option like this: $ tcpdump -i /dev/net/ipro1000/0

When you don't specify anything, it's supposed to take the first interface, and that's obviously not working. I don't know why it doesn't print an error in this case; I think this might be a bug in tcpdump itself.

comment:2 Changed 11 years ago by bga

As I said, tcpdump with any options just prints "tcpdump:" and exists. This includes:

tcpdump -i /dev/net/ipro1000/0

comment:3 Changed 11 years ago by bga

I mean "exits", not "exists". :)

comment:4 Changed 11 years ago by axeld

Priority: lownormal

Ah, I thought that you wanted to say "without" instead. The problem I thought you meant is fixed in hrev24441. It didn't print an error because I didn't return one :-) "tcpdump" works fine here, and I can't reproduce this, if any error remains.

comment:5 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Looks like someone could still had problems... fixed by James Woodcock in hrev25601.

Note: See TracTickets for help on using tickets.