Opened 9 years ago

Closed 6 years ago

#1935 closed enhancement (fixed)

Implement Real-Time Signal Support

Reported by: bonefish Owned by: bonefish
Priority: normal Milestone: R1
Component: System/POSIX Version:
Keywords: Cc: service.exchange@…
Blocked By: Blocking: #2695, #4366, #5324, #5683, #5684
Has a Patch: no Platform: All

Description (last modified by bonefish)

This includes among other things implementing:

  • sigqueue()
  • the SA_SIGINFO flag of sigaction()
  • waitid()

Cf.: http://www.opengroup.org/onlinepubs/009695399/functions/xsh_chap02_04.html#tag_02_04_02

Change History (14)

comment:1 Changed 9 years ago by bonefish

  • Description modified (diff)

comment:2 Changed 8 years ago by bonefish

  • Blocking 4366 added

(In #4366) Dup of #1935.

comment:3 Changed 8 years ago by axeld

  • Owner changed from axeld to nobody
  • Version R1/pre-alpha1 deleted

comment:4 Changed 8 years ago by bonefish

  • Component changed from System/Kernel to System/POSIX

comment:5 Changed 7 years ago by bonefish

  • Blocking 5324 added

(In #5324) ucontext_t and mcontext_t should rather be added as part of implementing SA_SIGINFO (the only feature using these structures), which in turn should be implemented as part of real-time signal support. Cf. #1935.

comment:6 Changed 7 years ago by bonefish

  • Blocking 2695 added

(In #2695) Sorry for not doing this earlier. As discussed via mail, this feature cannot be implemented without real-time signal support. Therefore closing it as duplicate of #1935.

comment:7 Changed 7 years ago by bonefish

  • Owner changed from nobody to bonefish
  • Status changed from new to assigned

Partial patch to support SA_SIGINFO by andreasf.

comment:8 Changed 7 years ago by bonefish

  • Blocking 5683 added

comment:9 Changed 7 years ago by bonefish

  • Blocking 5684 added

comment:10 in reply to: ↑ description Changed 7 years ago by andreasf

For reference, here's a link to Issue 7 (POSIX.1-2008): http://www.opengroup.org/onlinepubs/9699919799/functions/V2_chap02.html#tag_15_04_02

The summary still points to Issue 6 (POSIX.1-2004).

comment:11 Changed 7 years ago by HaikuBot

  • Cc service.exchange@… added

comment:12 Changed 6 years ago by bonefish

I added a wiki page detailing on the signal related issues and suggesting implementation hints. I'll see, if I can start working on the implementation in the next days.

comment:13 Changed 6 years ago by bonefish

  • Status changed from assigned to in-progress

Working on this in my signals branch.

comment:14 Changed 6 years ago by bonefish

  • Resolution set to fixed
  • Status changed from in-progress to closed

Implemented in hrev42116.

Note: See TracTickets for help on using tickets.