Opened 12 years ago

Closed 4 years ago

Last modified 6 months ago

#1973 closed bug (fixed)

Video drivers and VESA driver don't work with VIA K8N800 video chipset

Reported by: zaranthos Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/VIA Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #7662 Blocking:
Has a Patch: no Platform: x86

Description

The video driver for the VIA K8N800 chipset isn't working and the VESA modes also fail to work on an ECS 536 laptop. Updating the BIOS to the latest version didn't help. The video driver loads but displays garbage graphics on the screen. In vesa modes the Haiku logo seems to display in different modes until about the time Tracker loads and then the screen goes black. None of the vesa modes work correctly.

Full laptop specs can be found here: http://www.ecs.com.tw/ECSWebSite/Products/ProductsDetail.aspx?detailid=520&CategoryID=3&DetailName=Specification&MenuID=59&LanID=0

Attachments (1)

ECS 536 laptop.zip (53.4 KB ) - added by zaranthos 12 years ago.
syslogs and video dumps

Download all attachments as: .zip

Change History (17)

comment:1 by korli, 12 years ago

Could you try to activate debug console output and take some pictures of each screen ?

comment:2 by axeld, 12 years ago

Have you tried to enable "Use fail-safe video mode" from the safe-mode boot menu?

comment:3 by axeld, 12 years ago

The problem might be gone with hrev24620 - I've removed the VIA driver for now.

by zaranthos, 12 years ago

Attachment: ECS 536 laptop.zip added

syslogs and video dumps

comment:4 by zaranthos, 12 years ago

I've enabled syslog (no serial port for serial debugging. Does it work via USB?). I copied the via.settings file from Zeta to Haiku to capture logging and dump the video ROM file also in case that's useful. I have a few syslogs with different options in case that helps. I'll attach the file with logs and ROM dump.

comment:5 by zaranthos, 12 years ago

Tried hrev24609 (have to wait for the next nightly build for 24620) and fail safe video works. I did fail safe video plus VESA 1024x768 and it worked! That's not how any other version of BeOS works though since I was always able to just select the VESA mode I wanted without setting fail safe video. DHCP doesn't work with the network chipset and I can't tell if static works yet since there is no web browser. The sound isn't working either. Hopefully some of this info is helpful. :)

comment:6 by korli, 11 years ago

Owner: changed from axeld to rudolfc

Reassigning to Rudolf in case he has an idea.

comment:7 by scottmc, 8 years ago

Blocking: 7662 added

comment:8 by scottmc, 7 years ago

Any chance you still have this old hardware? Can you try running the latest Haiku release on it, and update this ticket?

comment:9 by rudolfc, 7 years ago

No sorry. I sent this hardware i had to axel. This driver is beyond my reaxh now. Bye! Rudolf.

comment:10 by rudolfc, 4 years ago

Hello,

So, what are the chances of me having this hardware suddenly.. but I have. Testing the driver accelerant, black screen currently (the kerneldriver had a fault somehow crashing the system while mapping areas but I've just fixed that).

Note please that this card has a not so good bios (?) and indeed the display can be garbage using default vesa mode. Looks like this happens because the card BIOS mode set is beyond the monitor's specs.. (at least for me) The monitor has to downscale the image (digital panel connected via a VGA connection). Hsync seems to not be solid, unless you manually select 1024x768 mode before haiku boots.

Anyhow, I hope to be able to have a decent look at the black screen within weeks. I'll get back on this.

Bye!

Rudolf.

comment:11 by rudolfc, 4 years ago

Hi again,

since hrev50025 this card works (tested by myself). Closing ticket. If this is the only reason this driver was removed from the build Axel, I guess you can add it again.

Bye!

Rudolf.

comment:12 by rudolfc, 4 years ago

Resolution: fixed
Status: newclosed

comment:13 by rudolfc, 4 years ago

Cc: axeld@… added

comment:14 by rudolfc, 4 years ago

Axel, hope this is OK.. can you add this driver back to the image? the problem was fixed.. or is there another reason it's not in there?

comment:15 by axeld, 4 years ago

Cc: axeld@… removed

I don't remember, but I don't mind finding it out again ;-) I only found hrev24620 which removes the driver, but it doesn't really go into details as to why.

comment:16 by waddlesplash, 6 months ago

Blocked By: 7662 added
Blocking: 7662 removed
Note: See TracTickets for help on using tickets.