Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1974 closed bug (fixed)

PackageInstaller unable to open Subversion.pkg file from haiku-os.org

Reported by: scottmc Owned by: sil2100
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

PackageInstaller not able to open the Subversion .pkg file on Haiku-os.org. Seems this would be a requirement for someone to be able to set up a build system on Haiku. ;) Screenshot attached.

Attachments (2)

screen2.png (31.9 KB ) - added by scottmc 11 years ago.
svn_pkg_success.png (64.6 KB ) - added by umccullough 11 years ago.
Successful package install here

Download all attachments as: .zip

Change History (12)

by scottmc, 11 years ago

Attachment: screen2.png added

comment:1 by umccullough, 11 years ago

Worked fine for me - just launch PackageInstaller (I navigated to the apps dir and launched it by double-clicking) and then use the open dialog to launch the subversion package. Then you just click on the Subversion banner that shows in the middle of the screeen.

comment:2 by scottmc, 11 years ago

You're right, that worked. So maybe this isn't a bug, or maybe the bug is that PackageInstaller doesn't work correctly from the commandline?

by umccullough, 11 years ago

Attachment: svn_pkg_success.png added

Successful package install here

comment:3 by axeld, 11 years ago

What we can definitely agree on is that it should just work by double clicking the package :-)

comment:4 by umccullough, 11 years ago

BTW, I was able to make it work from the commandline by qualifying the path to the package as such:

$ PackageInstaller ./Subversion-1.1.3.pkg

comment:5 by j_freeman, 11 years ago

Same thing happens to me on real hardware with hrev24609.

comment:6 by sil2100, 11 years ago

Owner: changed from axeld to sil2100

Interesting. I will look into this issue as soon as possible, since it's more or less my responsibility ;-) If, of course, there are no objections.

comment:7 by scottmc, 11 years ago

This seems to be fixed with recent builds, after hrev24752 or so. Can anyone else confirm?

comment:8 by scottmc, 11 years ago

I checked this again tonight with some old package files and just double clicking the pkg file PackageInstaller opened them up as expected. Seems this one can be closed.

comment:9 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

Thanks for checking!

comment:10 by sil2100, 11 years ago

I also was not able to reproduce the bug in the recent builds. Nice to see it's the same for someone else too. Thanks.

Note: See TracTickets for help on using tickets.