Opened 11 years ago

Closed 11 years ago

#1991 closed bug (fixed)

jam clean fails on haiku-host

Reported by: kaoutsis Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

/haiku-src/develop/HaikuTree/trunk>./configure --include-gpl-addons --use-gcc-pipe
/haiku-src/develop/HaikuTree/trunk>jam clean
...found 1 target(s)...
...updating 1 target(s)...
Clean clean 
/bin/sh: -c: line 2: unexpected EOF while looking for matching `"'
/bin/sh: -c: line 3: syntax error: unexpected end of file

rm -f "generated/objects/haiku/x86/release/add-ons/accelerants/common/libaccelerantscommon.a" "generated/objects/haiku/x86/release/add-ons/accelerants/common/create_display_modes.o" "generated/objects/haiku/x86/release/add-ons/accelerants/common/ddc.o" "generated/objects/haiku/x86/release/add-ons/accelerants/common/decode_edid.o" "generated/objects/haiku/x86/release/add-ons/accelerants/common/dump_edid.o" "generated/objects/haiku/x86/release/add-ons/accelerants/common/i2c.o" "generated/objects/haiku/x86/release/add-ons/accelerants/intel_extreme/intel_extreme.accelerant" 
[...]
"generated/objects/haiku/x86/release/add-ons/kernel/drivers/graphics/vesa/vga.o"

...failed Clean clean ...
...failed updating 1 target(s)...
/haiku-src/develop/HaikuTree/trunk>                                                                      

Attachments (1)

built-on-haiku.png (96.7 KB) - added by scottmc 11 years ago.
screencap of haiku building on haiku - confirming this fixed it

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by kaoutsis

/haiku-src/develop/HaikuTree/trunk>uname -a Haiku unknown 1 hrev24691 Mar 30 2008 21:17:59 BePC BeOS

comment:2 Changed 11 years ago by bonefish

The reason for this is, that jam's configured maximal command line length (40 KB) is greater than our kernel limit (16 KB), hence the line gets truncated, resulting in the above error.

Interestingly the auto tools configure scripts determine our command line length to be 4096 bytes. Probably a limit our bash is configured to.

comment:3 Changed 11 years ago by scottmc

Cc: haiku@… added

This is still happening as of hrev25993 and I believe should be added as a blocker to self hosting. I run into the vfork issue when building on Haiku with 512Meg of ram, but when increasing the ram to 1GB it then runs into this issue.

comment:4 in reply to:  3 Changed 11 years ago by bonefish

Replying to scottmc:

This is still happening as of hrev25993 and I believe should be added as a blocker to self hosting. I run into the vfork issue when building on Haiku with 512Meg of ram, but when increasing the ram to 1GB it then runs into this issue.

I don't think, this ticket is related to the memory problem. As I commented earlier it was most likely caused by the command line length limit and should be fixed in hrev26119. I haven't tested it yet though and probably won't anytime soon. If anyone can verify that it's fixed, please close the ticket.

comment:5 Changed 11 years ago by donn

jam, and "jam clean", on haiku trunk, works fine for me as of hrev26121.

comment:6 Changed 11 years ago by bonefish

Resolution: fixed
Status: newclosed

Thanks!

Changed 11 years ago by scottmc

Attachment: built-on-haiku.png added

screencap of haiku building on haiku - confirming this fixed it

Note: See TracTickets for help on using tickets.