Opened 11 years ago

Closed 11 years ago

#2018 closed bug (fixed)

libpng needs update >= 1.2.28 to fix security issue

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Attachments (1)

png-1.2.26-to-1.2.29.diff (22.8 KB) - added by scottmc 11 years ago.
diff file to update libpng from 1.2.26 to 1.2.29

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Updated to 1.2.26 in hrev24758

comment:2 Changed 11 years ago by scottmc

Seems they fixed another security issue in 1.2.26, 1.2.28 is out as I write this.

comment:3 Changed 11 years ago by scottmc

Resolution: fixed
Status: closedreopened
Summary: libpng needs update to 1.2.25 to fix security issuelibpng needs update to 1.2.28 to fix security issue

1.2.28 compiles and passes all tests, just need to update in tree: http://tools.assembla.com/BePorts/wiki/media-libs/libpng Reopened the ticket due to it be labeled a security fix on libpng's site.

comment:4 Changed 11 years ago by scottmc

Summary: libpng needs update to 1.2.28 to fix security issuelibpng needs update >= 1.2.28 to fix security issue

v1.2.29 is now out.

Changed 11 years ago by scottmc

Attachment: png-1.2.26-to-1.2.29.diff added

diff file to update libpng from 1.2.26 to 1.2.29

comment:5 Changed 11 years ago by scottmc

I downloaded the 1.2.29 source code files and dropped the matching ones over the 1.2.26 in my haiku source png folders, total of 19 'c' files and 2 'h' files, skipping the pngtest.c file. Then ran svn diff. output diff file attached.

comment:6 Changed 11 years ago by scottmc

libpng 1.2.30 has now been released.

comment:7 Changed 11 years ago by korli

Resolution: fixed
Status: reopenedclosed

Updated in hrev27012.

comment:8 Changed 11 years ago by aldeck

Resolution: fixed
Status: closedreopened

There is a problem with this new libpng version. The image in Vision's setup/(first startup) window is not loaded anymore.

Here's what i get on terminal output:

libpng error: x[9C]b[60]: invalid chunk type

comment:9 Changed 11 years ago by korli

Will update with 1.2.31 ASAP.

comment:10 Changed 11 years ago by korli

Resolution: fixed
Status: reopenedclosed

Updated in hrev27115.

Note: See TracTickets for help on using tickets.