Opened 11 years ago

Closed 11 years ago

#2019 closed bug (duplicate)

page fault when block writer notifies an invalid hook with an idle event

Reported by: korli Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The original error is a pagefault. I added a check with a panic in block_cache.cpp in the function notify_transaction_listeners() just before the hook call (the check was on hook->hook being equals to 0xdeadbeef)

The session log gives details on the cache and the transaction.

Attachments (1)

serial.txt (26.7 KB) - added by korli 11 years ago.
debug session

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by korli

Attachment: serial.txt added

debug session

comment:1 Changed 11 years ago by korli

I added the following lines for debug purposes :

+               if (hook == (void *)0xdeadbeef || !hook->hook || hook->hook == (void *)0xdeadbeef)
+                       panic("notify_transaction_listeners cache %p transaction %p, hook %p %pi, event %ld\n", cache, transaction, hook, hook->hook, event);
                hook->hook(transaction->id, event, hook->data);

comment:2 Changed 11 years ago by axeld

Resolution: duplicate
Status: newclosed

Thanks for the info, but it's a duplicate of #2008 (as I didn't manage to fix that one correcty on first try).

Note: See TracTickets for help on using tickets.