Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2056 closed bug (invalid)

Trouble detecting audio CDs

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It was working in hrev24752 but seems to not be working in hrev24860 Tracker doesn't show any audio cds to mount, cdplayer says no disc, but if you press play it will play the cd, but the audio is broken up. This is on real hardware. I still had one of my two haiku partitions setup with hrev24752 and it was able to detect the audio cds there and auto mounted them, but after wiping it out and putting hrev24860 on it, I got the same result as on my other hrev24860 partition, no detect of audio cds.

Change History (3)

comment:1 Changed 11 years ago by mmlr

I think that is expected behavior right now. Ingo changed the filesystem interface and only ported over BFS so far. So you currently won't be able to mount either CDs (iso9660), FAT or NTFS volumes, as those filesystems have to be adapted to the new interface first. They are currently not in the image for that reason.

comment:2 Changed 11 years ago by bonefish

Resolution: invalid
Status: newclosed

Exactly. This is not a bug, just a feature that is disabled for a while.

comment:3 Changed 11 years ago by scottmc

Ok, then that explains why the only CD that showed up in my testing of hrev24860 was the BFS session on the WildCard Design Last Chance CD. ;)

Note: See TracTickets for help on using tickets.