Opened 11 years ago

Closed 11 years ago

#2057 closed bug (fixed)

'IFS' screensaver crash

Reported by: meanwhile Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Black screen only...happened on Haiku hrev24868.

Attachments (2)

IFSdebug.txt (2.0 KB ) - added by meanwhile 11 years ago.
IFSdebug2.txt (2.0 KB ) - added by meanwhile 11 years ago.

Download all attachments as: .zip

Change History (6)

by meanwhile, 11 years ago

Attachment: IFSdebug.txt added

by meanwhile, 11 years ago

Attachment: IFSdebug2.txt added

comment:1 by meanwhile, 11 years ago

Got the screensaver working only in a combination of lower resolution/less colors, although the error message shows up here too (after closing the screensaver window). It seems that another bug is related: #2182. Graphics card used is NeoMagic MagicMedia 256AV (NM2200) 2.5M on a Thinkpad 570. Added the debug info that came with this tryout.

in reply to:  1 comment:2 by aldeck, 11 years ago

Replying to meanwhile:

Got the screensaver working only in a combination of lower resolution/less colors, although the error message shows up here too (after closing the screensaver window).

Looking at the attachments (by the way, please type 'bt' in gdb to print the full backtrace), the crash seems to be caused by #2287 wich should be fixed now.

The black screen and the crash seems to be two different issues. Can you test again?

comment:3 by meanwhile, 11 years ago

Tested in hrev25770 and all's well, thanks. (No black screen anymore; this was indeed another matter that's been clarified as well)

comment:4 by aldeck, 11 years ago

Resolution: fixed
Status: newclosed

Forgot to close that one.

Note: See TracTickets for help on using tickets.