Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2102 closed bug (fixed)

Unarchived BBox doesn't draw its label

Reported by: shinta Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Unarchived BBox doesn't draw its label. It draws dirty line. See the screenshot.

Haiku: hrev25042 (patched #2099 fStyle initializing) SHINTA

Attachments (2)

UnarchivedBBox.png (1.1 KB) - added by shinta 11 years ago.
TestBox.zip (32.8 KB) - added by shinta 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by shinta

Attachment: UnarchivedBBox.png added

comment:1 Changed 11 years ago by shinta

It seems to be caused by BFont::SetShear()'s bug.

SetShear()'s argument is within the range 45.0 to 135.0 by Be Book. If the argument is out of range, the argument is adjusted. But, SetShear() doesn't seem to adjust the argument when the argument is -1.

Source code for adjusting SetShear()'s argument isn't found in Font.cpp. Sorry, but, I can't correct this bug.

comment:2 Changed 11 years ago by korli

Could you please provide your testcase application ?

Changed 11 years ago by shinta

Attachment: TestBox.zip added

comment:3 Changed 11 years ago by shinta

I uploaded TextBox.zip. Please place "Box.rsrc" to /boot/home and run the test app, then click the button.

comment:4 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Should be fixed in hrev25220

comment:5 Changed 11 years ago by shinta

Thanks.

Note: See TracTickets for help on using tickets.