Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2127 closed bug (fixed)

USB drive published name incorrect

Reported by: emitrax Owned by: mmlr
Priority: normal Milestone: R1
Component: File Systems/FAT Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Screenshot is better than many words.

Attachments (1)

noname.jpg (84.8 KB) - added by emitrax 11 years ago.
noname

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by emitrax

Attachment: noname.jpg added

noname

comment:1 Changed 11 years ago by mmlr

Owner: changed from axeld to mmlr
Status: newassigned

I'm going to investigate that. Also going to check why volumes are visible as "NO NAME" in the mount menu but then have a real name after being mounted and why there are entries with invalid characters in the mount menu when a USB mass storage device is inserted...

comment:2 Changed 11 years ago by mmlr

Resolution: fixed
Status: assignedclosed

In fact the name wasn't incorrect. It was just what the FAT filesystem read directly from disk, where spaces are used to pad the fixed width label field. Still there was a bug where the name was reported differently to the disk device manager and to fs stat reads what resulted in a different name being visible in the mount menu and after mounting. Both is fixed in hrev25828. The strange characters in the mount menu I mentioned above were caused by outdated cdda and ntfs filesystem add-ons that still provided the old fs API but weren't removed on my installation (so that was no bug but my setup).

comment:3 Changed 11 years ago by emitrax

Thanks for fixing it. Now "no name" is displayed when listing the root directory.

However, a different problem is the color used, green and blue (I think), which makes the name of the directory totally unreadable!

Note: See TracTickets for help on using tickets.