Opened 11 years ago

Closed 10 years ago

#2134 closed bug (fixed)

the text in a selectable text view with/or without scrollbar is moving up and down constantly while the left button is kept pressed

Reported by: kaoutsis Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking: #3235
Has a Patch: no Platform: All

Description

hrev25112, for example, while the Mail Daemon Status log window from #2133 is on the screen, select a text with the left button of the mouse, and keep the button pressed: all the text in the view is moving up and down constantly, while the left mouse button is kept pressed.

Change History (6)

comment:1 Changed 11 years ago by kaoutsis

another way to reproduce is :

  • open StyledEdit
  • select File > Save As
  • move the mouse pointer inside

name text field

  • press and hold the left mouse button:

you will see the 'Untitled 1' to move a bit up and down periodically.

comment:2 Changed 11 years ago by kaoutsis

Summary: the text in a selectable text view with scrollbar is moving up and down constantly while the left button is kept pressedthe text in a selectable text view with/or without scrollbar is moving up and down constantly while the left button is kept pressed

i found another example to reproduce the bug: 1) Open DataTranslations pref. app 2) From the list, find and click <PNG images> 3) Right of the list, there is a selectable text view that says: "libpng version 1.2.26 - April 2, 2008 ..." click and hold the left mouse button: The whole text is 'dancing' up and down constantly, as long as the button is kept pressed.

comment:3 Changed 11 years ago by scottmc

In hrev27904 this no longer happens in the PNGTranslator, but it still happens in the Save As text field for StyledEdit. Not sure when it got fixed for the PNGTranslator case, but I do recall seeing it still happen there just a few weeks ago.

comment:4 Changed 10 years ago by scottmc

Cc: haiku@… added

It still happens in the PNGTranslator as of hrev28291.

comment:5 Changed 10 years ago by mmlr

Blocking: 3235 added

(In #3235) Another duplicate of #2134.

comment:6 Changed 10 years ago by jackburton

Resolution: fixed
Status: newclosed

Fixed since some time already (probably by some commit by zooey or stippi)

Note: See TracTickets for help on using tickets.