Opened 11 years ago

Closed 11 years ago

#2166 closed bug (duplicate)

KDL: vnode 3:1574140 already exists

Reported by: andreasf Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: bga
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

PANIC: vnode 3:1574140 already exists (node = 0x919bd480, vnode->node = 0x919bd600)!

Happened while running a configure script.

panic
<kernel>new_vnode
<bfs>New InodeAllocator block_runUi block_run  Inode
Create Inode Transaction Inode fs_vnode_ops
<bfs>bfs_create fs_volume fs_vnode
<kernel>create_vnode
file_create
<kernel>_user_open

Change History (4)

comment:1 by mmlr, 11 years ago

This might be a duplicate of bug #1914. The last parts of the stack traces both end up in Inode::Create() -> InodeAllocator::New() -> new_vnode() as far as I can see.

comment:2 by andreasf, 11 years ago

I don't think so:

For one thing, this partition is brand-new, it was created after encountering #2148.

It never happens when deactivating one HyperThreading core(?) in Pulse.

So I rather assume this is a locking regression caused by the recent Inode changes.

I also got a number of page faults with interrupts disabled lately but not with one core running only. This used to work much better a week or so ago.

comment:3 by bga, 11 years ago

Cc: bga added

comment:4 by axeld, 11 years ago

Resolution: duplicate
Status: newclosed

Well, you cannot really know if this is a duplicate of #1914 or not - in any case, both problems have the very same outcome, which is why I will close this bug now, in favor of the older one :-)

Note: See TracTickets for help on using tickets.