Opened 11 years ago

Closed 10 years ago

#2186 closed bug (fixed)

PANIC: vm_page_fault: unhandled page fault in kernel space (rev25270)

Reported by: kaliber Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

During "svn up"

bfs: Insert:1306: Name in use

vm_soft_fault: va 0x0 not covered by area in address space

vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x805b8393, write 0, user 0, thread 0xd5

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x0, ip 0x805b8393



Welcome to Kernel Debugging Land...

Running on CPU 0

kdebug> bt

stack trace for thread 213 "svn"

    kernel stack: 0x90aeb000 to 0x90aef000

      user stack: 0x7efe7000 to 0x7ffe7000

frame            caller     <image>:function + offset

90aee088 (+  52) 8008aea7   <kernel>:invoke_debugger_command + 0x00cf

90aee0bc (+  64) 8008bc50   <kernel>:_ParseCommand__16ExpressionParserRi + 0x01f8

90aee0fc (+  48) 8008b642   <kernel>:EvaluateCommand__16ExpressionParserPCcRi + 0x01de

90aee12c (+ 228) 8008cd64   <kernel>:evaluate_debug_command + 0x0088

90aee210 (+  64) 800899e2   <kernel>:kernel_debugger_loop__Fv + 0x017a

90aee250 (+  48) 8008a695   <kernel>:kernel_debugger + 0x010d

90aee280 (+ 192) 8008a57d   <kernel>:panic + 0x0029

90aee340 (+  64) 80061bd3   <kernel>:vm_page_fault + 0x00ab

90aee380 (+  64) 80097651   <kernel>:page_fault_exception + 0x00b1

90aee3c0 (+  12) 8009ad2d   <kernel>:int_bottom + 0x001d (nearest)

iframe at 0x90aee3cc (end = 0x90aee424)

 eax 0x0            ebx 0x805bde24      ecx 0x90b99000   edx 0x246

 esi 0x1            edi 0x90b9b000      ebp 0x90aee434   esp 0x90aee400

 eip 0x805b8393  eflags 0x10282    

 vector: 0xe, error code: 0x0

90aee3cc (+ 104) 805b8393   <ide>:sim_scsi_io + 0x0123

90aee434 (+  64) 8069bb01   <scsi>:scsi_async_io + 0x0245

90aee474 (+  96) 806ade4f   <scsi_periph>:periph_read_write + 0x01fb

90aee4d4 (+  80) 806adbfb   <scsi_periph>:periph_read + 0x003f

90aee524 (+  64) 806a9d3e   <scsi_dsk>:das_read + 0x0042

90aee564 (+ 160) 805a4bb4   <block_io>:block_io_readv_int + 0x042c

90aee604 (+  80) 805a5390   <block_io>:block_io_read + 0x0040

90aee654 (+  64) 80046a2e   <kernel>:Process__11IOSchedulerR9IORequest + 0x0052

90aee694 (+ 112) 80041f25   <kernel>:devfs_read__FP9fs_volumeP8fs_vnodePvxT2PUl + 0x0141

90aee704 (+  64) 800534f2   <kernel>:file_read__FP15file_descriptorxPvPUl + 0x0036

90aee744 (+  96) 80044db5   <kernel>:_kern_read + 0x0145

90aee7a4 (+  64) 800a3062   <kernel>:read_pos + 0x0036

90aee7e4 (+  80) 8006a467   <kernel>:get_cached_block__FP11block_cachexPbb + 0x010b

90aee834 (+  80) 8006d173   <kernel>:block_cache_get_etc + 0x004b

90aee884 (+  48) 8006d21c   <kernel>:block_cache_get + 0x0020

90aee8b4 (+  96) 8057f599   <bfs>:InternalSetTo__10CachedNodeP11Transactionx + 0x0151

90aee914 (+  48) 8057f025   <bfs>:SetTo__10CachedNodexb + 0x00d1

90aee944 (+ 112) 80580858   <bfs>:_SeekDown__9BPlusTreeRt5Stack1Z12node_and_keyPCUcUs + 0x01e4

90aee9b4 (+ 464) 805819b6   <bfs>:Insert__9BPlusTreeR11TransactionPCUcUsx + 0x00d6

90aeeb84 (+  80) 80586ae9   <bfs>:Update__5IndexR11TransactionPCclPCUcUsT4UsP5Inode + 0x0235

90aeebd4 (+  80) 80586c4b   <bfs>:UpdateName__5IndexR11TransactionPCcT2P5Inode + 0x00bb

90aeec24 (+  64) 80586b4e   <bfs>:InsertName__5IndexR11TransactionPCcP5Inode + 0x002e

90aeec64 (+ 144) 8058dd1d   <bfs>:Create__5InodeR11TransactionP5InodePCcliUlPbPxPP5InodeP12fs_vnode_opsUl + 0x07dd

90aeecf4 (+  96) 80596829   <bfs>:bfs_create__FP9fs_volumeP8fs_vnodePCciiPPvPx + 0x0125

90aeed54 (+  96) 80052f0d   <kernel>:create_vnode__FP5vnodePCciib + 0x00b5

90aeedb4 (+ 320) 8005325a   <kernel>:file_create__FiPciib + 0x005a

90aeeef4 (+  80) 8005856c   <kernel>:_user_open + 0x00bc

90aeef44 (+ 100) 8009aea2   <kernel>:pre_syscall_debug_done + 0x0002 (nearest)

iframe at 0x90aeefa8 (end = 0x90aef000)

 eax 0x4f           ebx 0x462c30        ecx 0x7ffe63d4   edx 0xffff0104

 esi 0x18d70fc8     edi 0x18d71ee0      ebp 0x7ffe6400   esp 0x90aeefdc

 eip 0xffff0104  eflags 0x202      

 vector: 0x63, error code: 0x0

90aeefa8 (+   0) ffff0104

7ffe6400 (+  64) 003293be   <libapr-1.so>:apr_file_open + 0x0136

7ffe6440 (+  64) 002c7ff5   <libsvn_subr-1.so>:svn_io_file_open + 0x0049

7ffe6480 (+  64) 0023ad85   <libsvn_wc-1.so>:svn_wc__prop_base_path + 0x00e1 (nearest)

7ffe64c0 (+  64) 0023af23   <libsvn_wc-1.so>:svn_wc__open_adm_file + 0x0037

7ffe6500 (+  64) 0023b8e5   <libsvn_wc-1.so>:svn_wc__sync_props + 0x03fd (nearest)

7ffe6540 (+  64) 0023bb99   <libsvn_wc-1.so>:svn_wc__sync_props + 0x06b1 (nearest)

7ffe6580 (+  64) 0023bc46   <libsvn_wc-1.so>:svn_wc_ensure_adm + 0x005a

7ffe65c0 (+  64) 0024d480   <libsvn_wc-1.so>:svn_wc__maybe_set_executable + 0x0884 (nearest)

Attachments (1)

bug.txt (44.2 KB) - added by kaliber 11 years ago.
Full serial output

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by kaliber

Attachment: bug.txt added

Full serial output

comment:1 Changed 10 years ago by kaliber

It looks like it have been fixed. I cannot reproduce it with current revision. Please close the bug.

comment:2 Changed 10 years ago by leavengood

Resolution: fixed
Status: newclosed

Marking fixed and closing.

Note: See TracTickets for help on using tickets.