Opened 11 years ago

Closed 10 years ago

#2195 closed enhancement (fixed)

[Pe] puts libnetwork into R5 compatibility mode

Reported by: andreasf Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Currently, the Pe Optional Package on Pe startup leads to the debug message

libnetwork.so running in R5 compatibility mode.

It should be recompiled/updated to avoid this.

Change History (8)

comment:1 by scottmc, 11 years ago

Cc: haiku@… added

Perhaps this should be moved to R1/alpha, as Pe is to be included. Should be easy enough to fix. Also might want to fix it to use /boot/common: http://www.freelists.org/archives/pedevel/09-2008/msg00000.html

comment:2 by axeld, 11 years ago

It doesn't hurt anyone, so I don't think we should move it to R1/alpha. But if someone fixes it before the release, all the better :-)

comment:3 by scottmc, 11 years ago

This was actually fixed in pe r529. But let's leave this ticket open until a new binary is ready to be added to the optional packages. I can probably work on it in the next week unless someone beats me to it. I just sent in another patch for pe to fix a couple of build warnings.

comment:4 by scottmc, 11 years ago

I suspect this is fixed now with PE-2.4.1-RC3 being added to Haiku optional package?

comment:5 by anevilyak, 11 years ago

I'll need to double check to make sure my optional package is in fact the most current one, but at least the build I was running yesterday still printed that message.

comment:6 by stippi, 11 years ago

I am guilty of having built Pe on ZETA (with R5 headers).

comment:7 by mmadia, 10 years ago

Requesting this ticket to be closed. Pe is available as both a gcc2 and gcc4 binary. Hosted at http://haiku-files.org/files/optional-packages/

comment:8 by anevilyak, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.