Opened 11 years ago

Closed 11 years ago

#2194 closed bug (duplicate)

KDL while using WGET with rt18139

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

typing by hand so only putting in the first part here. If you need more let me know.

PANIC: vm_page fault: unhandle page fault in kernel space at 0x4f951caf, ip 0x80098c98

Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> sc stack trace for thread 64 "/dev/net/rtl18139/0 reader"

kernel stack: 0x8052c000 to 0x80530000

frame caller <image>:function + offset 8052fa20 (+ 52) 8008b63f <kernel>:invoke_debugger_command + 0x00cf 8052fa54 (+ 64) 8008c3e8 <kernel>:_ParseCommand16ExpressionParserRi + 0x01f9

To reproduce, boot a fresh dev image of hrev25283 on real hardware with a Realtek RTL-8139/8139C/8139C+ network controller. Attempt to use WGET to grab a file, KDL unsues about 70% of the way through.

Change History (3)

comment:1 Changed 11 years ago by bonefish

Up to (and including) the "<kernel>:panic" line the beginnings of all stack traces are the same. So if you have to type anything manually the "PANIC: ..." line, the name of the thread, and a few lines of the stack trace after the "<kernel>:panic" will be of most interest. You can also omit all numbers in the stack trace.

comment:2 Changed 11 years ago by scottmc

This one and #2268 are dupes of 1641, please close. I will follow up on #1641. I saw this happen again with hrev25673, I'm going to try to capture it with a serial debug setup and will post the output on ticket #1641 if/when I am successful in capturing something useful.

comment:3 Changed 11 years ago by stippi

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.