Opened 13 years ago

Closed 12 years ago

#227 closed bug (fixed)

[kernel] memory and semaphore leaks

Reported by: diver Owned by: axeld
Priority: critical Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: umccullough@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

You could see memory and semaphore leaks running sysinfo in terminal several times.

Change History (9)

comment:1 Changed 13 years ago by diver

Tested with rev16521 under vmware.

comment:2 Changed 13 years ago by axeld

That's a known missing feature: when a team is forked (which happens when you start something from the shell), the shell's areas are copied-on-write, and that requires some new VM structures (which have semaphores as well). After an exec() these structures could be freed, but that's not done yet.

comment:3 Changed 13 years ago by axeld

* Bug 348 has been marked as a duplicate of this bug. *

comment:4 Changed 13 years ago by axeld

Cc: umccullough@… added

comment:5 Changed 13 years ago by johndrinkwater

Cc: john@… added

comment:6 Changed 13 years ago by diver

Summary: Haiku memory and semaphore leaks[kernel] memory and semaphore leaks

comment:7 Changed 12 years ago by axeld

Platform: All
Resolution: fixed
Status: newclosed

Fixed in hrev19041.

comment:8 Changed 12 years ago by diver

Resolution: fixed
Status: closedreopened

Checked with hrev19863 and it seems that this bug is still here, reopening?

comment:9 Changed 12 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Thanks for the note! I accidently reopened that bug obviously. It's now fixed in hrev19878.

Note: See TracTickets for help on using tickets.