Opened 11 years ago

Closed 11 years ago

#2288 closed bug (fixed)

KDL on rescanning of legacy drivers

Reported by: idefix Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

With hrev25684 the computer goes into KDL when I unplug my Wacom Graphire 2 USB pentablet. Previous revisions didn't show this behaviour (previous one I tested was 1 - 2 weeks old I think).

How to reproduce:

  • Start Haiku with tablet connected.
  • Pull USB plug out of USB port.
  • Haiku enters KDL.

I tested this two times, see attached syslog-outputs.

Attachments (2)

Syslog - wacom tablet unplugged.txt (50.1 KB ) - added by idefix 11 years ago.
First time
Syslog - wacom tablet unplugged 2.txt (45.8 KB ) - added by idefix 11 years ago.
Second time

Download all attachments as: .zip

Change History (5)

by idefix, 11 years ago

First time

by idefix, 11 years ago

Second time

comment:1 by idefix, 11 years ago

Looks like second text file didn't upload correctly: the beginning is truncated.

comment:2 by mmlr, 11 years ago

Owner: changed from mmlr to axeld
Summary: KDL when I unplug USB Wacom pentabletKDL on rescanning of legacy drivers

Assigning to Axel as this is caused by the new device manager. Unplugging any USB device will show this behaviour. Relabeling bug accordingly.

comment:3 by mmlr, 11 years ago

Resolution: fixed
Status: newclosed

Should be fixed in hrev25729 although this seems to need some more work anyway.

Note: See TracTickets for help on using tickets.