Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2289 closed bug (invalid)

scsi_dsk, scsi_cd broken, symbol api_version missing

Reported by: monni Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Some people actually use SCSI devices... erf...

Change History (3)

comment:1 by axeld, 11 years ago

Resolution: invalid
Status: newclosed

The device manager and architecture has recently received a major overhaul, and thus the system is not completely working yet. The missing components will be fixed over the next few days. In any case, the new device manager does not use the api_version symbol anymore. Also, scsi_dsk cannot be broken or you couldn't even run Haiku. I've ported scsi_cd today. Just be patient.

comment:2 by axeld, 11 years ago

BTW if you have a specific error that you don't think is right, please report it; it's not very helpful to have a generic report like this one.

comment:3 by monni, 11 years ago

If Haiku complains that mandatory driver symbol is missing, I don't think it is "too generic" even if it is false positive. And I can't run Haiku without hacks anyways because my system is SCSI-only and there is no boot module for AHA2940 yet, but I'm not adding that issue to this ticket.

Note: See TracTickets for help on using tickets.