Opened 11 years ago

Closed 10 years ago

#2319 closed bug (fixed)

consoled can't turn off caps lock

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If Haiku drops in kdl while caps lock was turned on, there is no way to turn it off. This will make any command typed in kdl session to not work.

Change History (9)

comment:1 by diver, 11 years ago

Summary: [conoled] can't turn off caps lock in kdl.[consoled] can't turn off caps lock in kdl.

comment:2 by axeld, 11 years ago

I can't reproduce this problem - when in KDL, the caps lock key is completely ignored. In fact, the system will only enter large letters when you press the shift key while inside KDL.

Do you have any special setup in order to reproduce this? (like a KVM switch, a USB keyboard with legacy BIOS support, etc.)

comment:3 by diver, 11 years ago

Nope, just simple ps/2 keyboard here. I think you tried F12 to enter in kdl, right? I think it could only be reproducible if you've been forced to enter kdl by a crash (app_server).

comment:4 by mmlr, 11 years ago

Note that what you get when for example app_server (or other GUI servers) crashes is not a KDL. It is a fullscreen GDB that is attached to the thread that crashed. The rest of the system will not be halted in those cases as would be the case if you actually entered KDL. Please clarify if it was indeed a KDL or just a GDB caused by a GUI server crash.

comment:5 by diver, 11 years ago

Yes, I think it was app_server crash.

comment:6 by axeld, 11 years ago

Summary: [consoled] can't turn off caps lock in kdl.consoled can't turn off caps lock

comment:7 by diver, 11 years ago

I had this problem several days ago again.

comment:8 by diver, 10 years ago

Component: SystemApplications/Command Line Tools

Can't reproduce anymore.

comment:9 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

Okidoki.

Note: See TracTickets for help on using tickets.