Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#232 closed bug (fixed)

StyledEdit Save Panel Bug

Reported by: murai@… Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In Save Panel, default filename(?), "save text" can"t delete or edit. ("save text" appears after deleting first default filename "Untitled 1". )

Change History (8)

comment:1 Changed 13 years ago by jackburton

That's very likely caused by my incorrect implementation of BTextView::AutoResize(). When you delete the text inside the BTextControl, the BTextView is shrinked to fit the text, thus revealing the BTextControl's label drawn under it.

comment:2 Changed 13 years ago by jackburton

Component: ApplicationsKits

comment:3 Changed 13 years ago by jackburton

I'll have a look

comment:4 Changed 13 years ago by jackburton

Owner: changed from sikosis to jackburton

comment:5 Changed 13 years ago by jackburton

Status: newassigned

comment:6 Changed 13 years ago by jackburton

Resolution: fixed

comment:7 Changed 13 years ago by jackburton

Fixed in rev 16579

comment:8 Changed 13 years ago by jackburton

Status: assignedclosed
Note: See TracTickets for help on using tickets.