Opened 13 years ago

Closed 12 years ago

#234 closed bug (fixed)

[Deskbar] dragging any icon over Deskbar crashes it

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

If you drag haiku volume icon from desktop or from Disks window over Deskbar several times crashes it or sometimes lockup Deskbar. I could take screenshot of sc/bt in debugger if needed. Tested with rev16521 under vmware.

Attachments (1)

deskbar.PNG (29.9 KB) - added by diver 13 years ago.
back trace

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by marcusoverhagen

dependson: 271

comment:2 Changed 13 years ago by marcusoverhagen

Owner: changed from axeld to mmlr

comment:3 Changed 13 years ago by johndrinkwater

I can't reproduce this with hrev17068, can you retest?

comment:4 Changed 13 years ago by mmlr

Should be fixed since hrev17101 at the latest.

comment:5 Changed 13 years ago by mmlr

Status: newclosed

comment:6 Changed 13 years ago by mmlr

Resolution: fixed

comment:7 Changed 13 years ago by diver

Resolution: fixed

comment:8 Changed 13 years ago by diver

Still happens in rev17101, reopening bug. back trace will follow.

comment:9 Changed 13 years ago by diver

Status: closedreopened

comment:10 Changed 13 years ago by diver

Cc: axeld@… added

comment:11 Changed 13 years ago by diver

Adding Axel as it could be Deskbar bug ;-)

Changed 13 years ago by diver

Attachment: deskbar.PNG added

back trace

comment:12 Changed 13 years ago by diver

Status: reopenednew

comment:13 Changed 13 years ago by diver

It seems like a Deskbar bug, as i've seen similar back trace on R5 too, so reassigning it to Axel :-)

comment:14 Changed 13 years ago by diver

Summary: [Deskbar] Dragging haiku volume icon over Deskbar crashes it[Deskbar] dragging any icon over Deskbar crashes it

comment:15 Changed 13 years ago by diver

Owner: changed from mmlr to axeld

comment:16 Changed 13 years ago by korli

bug_group: developers

comment:17 Changed 13 years ago by diver

It seems to be fixed now?

comment:18 Changed 13 years ago by diver

More tests shows that crashing bug is fixed indeed, but deskbar now locks up while dragging an icon over it several times, sweet ;-)

comment:19 Changed 12 years ago by jackburton

Description: modified (diff)
Platform: All
Resolution: fixed
Status: newclosed

This is fixed, probably when Axel introduced direct message passing.

Note: See TracTickets for help on using tickets.