Opened 11 years ago

Closed 11 years ago

#2340 closed bug (duplicate)

PANIC: release spinlock: [...]

Reported by: cpf_ Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

While trying to boot on VirtualBox: PANIC: release_spinlock: attempt to release lock 0x800db56c with interrupts enabled

With a polite invitation to debug the kernel and a "kdebug" shell.

I wouldn't know what to do to debug any part of any kernel :)

How to reproduce: Download the current raw image, bzip2 -d [the file], vditool DD [the image] [the vdi image] Import in virtualbox, try to boot (see the nice haiku boot splash, and later the white shell)

experienced behavior: doesn't do anything (except throw a console at me)

expected behavior: Boot

Hope this helps...

Change History (3)

comment:1 by umccullough, 11 years ago

Looks like duplicate of #1230 (see second screenshot) and #2202 as well.

Possibly are related to problems with virtualbox mentioned in #748 (also see virtualbox bug: http://www.virtualbox.org/ticket/56 )

Ultimately, there have been reports of successful boot under VirtualBox by enabling the hardware virtualization features on systems that support it, otherwise many have reported problems.

in reply to:  1 comment:2 by cpf_, 11 years ago

Replying to umccullough:

Looks like duplicate of #1230 (see second screenshot) and #2202 as well.

Possibly are related to problems with virtualbox mentioned in #748 (also see virtualbox bug: http://www.virtualbox.org/ticket/56 )

Ultimately, there have been reports of successful boot under VirtualBox by enabling the hardware virtualization features on systems that support it, otherwise many have reported problems.

After enabling the virtualization (hidden carefully) it works (boots at least). I didn't know this was a duplication - sorry for that, I tried to search before posting, but nothing similar came up on the search.

This can be closed to my regards.

comment:3 by axeld, 11 years ago

Resolution: duplicate
Status: newclosed

Thanks Urias for keeping track! :-) Duplicate of #1230.

Note: See TracTickets for help on using tickets.