Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2364 closed bug (fixed)

KDL when unplugging USB flash drive

Reported by: scottmc Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Not sure if this is using OHCI or EHCI. Happened with 2 different USB flash disks. This is on the AMD Geode board again, booting from an IDE/CF card. Attaching serial debug output from the two different USB flash devices.

Attachments (2)

usb-flash-drive-kdl.txt (63.0 KB) - added by scottmc 11 years ago.
This was with hrev25673
usb-flash-drive2-kdl.txt (31.4 KB) - added by scottmc 11 years ago.
from flash device #2, also on hrev25673

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by scottmc

Attachment: usb-flash-drive-kdl.txt added

This was with hrev25673

Changed 11 years ago by scottmc

Attachment: usb-flash-drive2-kdl.txt added

from flash device #2, also on hrev25673

comment:1 Changed 11 years ago by mmlr

Component: Drivers/USBSystem/Kernel
Status: newassigned

Well this revision is pretty dated already. There have been a few legacy device related fixes in the meantime. Please retest with a current revision. Also does this happen with hot-plugging the devices are do you boot with them and then remove them? Changing component to kernel as this is most probably related to the legacy driver system. Will have a look though.

comment:2 Changed 11 years ago by mmlr

Resolution: fixed
Status: assignedclosed

In fact hrev25724 fixed a guaranteed crash that would lead exactly to this stack trace. Also since the device was unplugged it is likely that this code path was actually taken. So I'll close this as fixed in hrev25724. Please reopen if this still happens with current revisions.

comment:3 Changed 11 years ago by scottmc

Confirmed that it's no longer dropping to KDL, tested with 25892. I attached fresh serial debug info to #1044, as there's perhaps some interesting info in there, perhaps not. OCHI support seems to be getting there though.

Note: See TracTickets for help on using tickets.