Opened 11 years ago

Closed 11 years ago

#2368 closed bug (fixed)

App-server crash when moving Deskbar modal window to another workspace

Reported by: idefix Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When I select the 'Restart...'-option in the Deskbar-menu a modal window is shown. This windows only shows on the workspace in which I choose to restart. As I moved the window to an other workspace, the app_server crashed.

Steps to reproduce:

  • Click 'Restart...' in the Deskbar-menu -> a modal window appears
  • Click and hold the window border
  • Press Alt-F2
  • Experience an app-server crash (as an added feature you can now scratch off the white surface and reveal the desktop)

Attachments (1)

app_server crash.jpg (296.5 KB) - added by idefix 11 years ago.
Photo of crash

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by idefix

Forgot to say this is with hrev25892.

Changed 11 years ago by idefix

Attachment: app_server crash.jpg added

Photo of crash

comment:2 Changed 11 years ago by idefix

Summary: App-server crash when moving Deskbar modal windowApp-server crash when moving Deskbar modal window to another workspace

comment:3 Changed 11 years ago by idefix

The app_server crashes when the mouse-button is released, but not always.

I noticed another bug when investigating this bug: When switched to the second workspace (by Alt-F2), move the mouse to another place and then release the mouse-button. When you switch back to the workspace where the window is, you'll notice it's at the position you released the mouse-button and not at the position when you switched workspaces.

comment:4 Changed 11 years ago by humdinger

On vmware, hrev27404, I cannot reproduce the crash.

I can confirm idefix' other observation the Restart-window remains in the old workspace when you switch to another one and is still moving with your mouse when you keep the button pressed. This movement is not seen in the Workspaces applet. Shouldn't the Restart-window show up on every workspace?

Should a seperate ticket be filed for that, so this one can be closed?

comment:5 Changed 11 years ago by idefix

Tested again with hrev27929 on two different computers.

The modal window is now shown on all workspaces. Switching to another workspace while dragging this window doesn't result in a crash anymore. The dragging behaviour is also correct when switching to another workspace: the modal window stays at the same position in the previous workspace (as the Workspaces applet now shows correctly).

This ticket can be closed.

comment:6 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.