Opened 11 years ago

Closed 11 years ago

#2369 closed bug (duplicate)

Booting halts

Reported by: mrsunshine Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Booting halts when using USB drivers (not even able to get into KDL) and without them, but then i can go into KDL and type "outb 0x4d0 1" "continue" and it boots fine after that.

Attachments (2)

cpuinfo (539 bytes) - added by mrsunshine 11 years ago.
cpuinfo
lspci (2.6 KB) - added by mrsunshine 11 years ago.
lspci

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by mrsunshine

Attachment: cpuinfo added

cpuinfo

Changed 11 years ago by mrsunshine

Attachment: lspci added

lspci

comment:1 Changed 11 years ago by dustin howett

Copying some of my random musings from IRC.

DHowett: MrSunshine: Hmm. 4d0 is ELCR1, which linux updates in its acpi-related boot code.
Haiku doesn't touch it in its acpi bus manager. Interesting.
DHowett: Haiku used to set everything to level-triggered. writing 1 to 4d0 sets int0 to level-
triggered and everything else (int 1-7) to edge-triggered
DHowett: maybe it would resolve it to just set the timer to level-triggered mode on boot. but I
don't know what that would cause for systems other than yours.

comment:2 Changed 11 years ago by mmlr

Resolution: duplicate
Status: newclosed

Duplicate of #2342.

Note: See TracTickets for help on using tickets.