Opened 11 years ago

Closed 11 years ago

#2382 closed bug (fixed)

[Terminal]: crash on BasicTerminalBuffer::_Scroll()

Reported by: emitrax Owned by: bonefish
Priority: high Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It happened while using vim and pressing ESC. I don't know how easy is to reproduce.

Attachments (1)

terminal3.jpg (135.5 KB) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by emitrax

Attachment: terminal3.jpg added

comment:1 Changed 11 years ago by bonefish

What revision was that? Before hrev25958 or after?

comment:2 Changed 11 years ago by emitrax

After.

comment:3 Changed 11 years ago by bonefish

I played a bit with vim, but couldn't reproduce the problem.

comment:4 Changed 11 years ago by emitrax

I actually managed to reproduce it quite easily again.

  • Open a file with vim that has more lines than the terminal can display
  • Maximize the window (you'll see that vim won't expand the text to the rest of the window)
  • In command mode (press esc), press the down key to scroll down the text

hrev25969 with vmware.

comment:5 Changed 11 years ago by bonefish

Should be fixed in hrev25973. Please verify.

comment:6 Changed 11 years ago by emitrax

Resolution: fixed
Status: newclosed

Issue seems fixed.

However a new incorrect behavior has come up.

Closing this one and opening a new one for the different issue. Thanks.

Note: See TracTickets for help on using tickets.