Opened 11 years ago

Closed 11 years ago

#2383 closed bug (fixed)

[Terminal]: redraw issues

Reported by: emitrax Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It's easy to reproduce. Open an empty file with vim, and resize the window (make it bigger). Honestly I don't know if the problem is about vim, terminal, or something else.

Another problem about resizing, I don't know if it's related, happens when you resize the terminal while the cursor is at the bottom of the window (e.g. there is some application output in the terminal). If you resize the window to the original size, the prompt doesn't go back to the end of the window, and the output is "lost". To see what I mean, the step required are the following:

  • Enlarge the terminal window
  • Run a command that fills the screen of output like ls -R /
  • Resize the window and then bring it to the original size

Attachments (1)

terminal_vim.jpg (24.1 KB ) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (5)

by emitrax, 11 years ago

Attachment: terminal_vim.jpg added

comment:1 by bonefish, 11 years ago

Status: newassigned

The vim problem is known and will go away when alternate screen buffer is implemented. It will use a different resizing mechanism.

The other "problem" is not a problem, but intended behavior. E.g. Konsole works just the same way.

comment:2 by emitrax, 11 years ago

If Konsole works the same way, IMHO it's a problem for Konsole too. Neither gnome-terminal, XFCE terminal, Eterm, aterm or any other terminal I've used behave that way. It's ugly and annoying. :)

in reply to:  2 comment:3 by bonefish, 11 years ago

Replying to emitrax:

If Konsole works the same way, IMHO it's a problem for Konsole too. Neither gnome-terminal, XFCE terminal, Eterm, aterm or any other terminal I've used behave that way. It's ugly and annoying. :)

I'd say resizing a terminal back and forth isn't a action that one does often enough to really bother whether some lines are scrolled up. I don't know about the other terminals programs, but at least xterm has a similar problem, just at the top of the screen: Enlarging the terminal after a Ctrl-L will move the cursor away from the top.

comment:4 by bonefish, 11 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev26031 (using alternate screen buffer). Resizing really works in vim not before hrev26034, though.

Note: See TracTickets for help on using tickets.