Opened 11 years ago

Closed 11 years ago

#2421 closed bug (fixed)

[Cortex] black backround of selected icons

Reported by: diver Owned by: mmlr
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Selected icons in Cortex (e.g. System Clock or Audio Mixer) have transparent background in BeOS, but black in Haiku.

Change History (2)

comment:1 by mmlr, 11 years ago

Owner: changed from axeld to mmlr
Status: newassigned

It's caused by drawing the icons async it seems. Investigating.

comment:2 by mmlr, 11 years ago

Resolution: fixed
Status: assignedclosed

Scratch that I obviously got mislead by a wrong test I did. The drawing command order obviously stays the same for async bitmap drawing, it's just not automatically synced, so it really has no influence on that. It was caused by wrong handling of bitmap drawing with B_OP_INVERT (not taking alpha into account) and it is fixed in hrev26067. Needs more investigation for other modes though.

Note: See TracTickets for help on using tickets.