Opened 11 years ago

Closed 11 years ago

#2440 closed bug (invalid)

echo $LIBRARY_PATH -> %A

Reported by: emitrax Owned by: bonefish
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

if you echo the LIBRARY_PATH that contains the current directory (.) as the first directory, %A will be printed instead of .:/

Tested with hrev26097.

Attachments (1)

echo_path.jpg (28.6 KB) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by bonefish

Can't reproduce. Setting LIBRARY_PATH to ".", ".:/" or ".:/$LIBRARY_PATH" produces just the expected result. Please add the steps to reproduce it.

BTW, any particular reason for assigning this to me?

Changed 11 years ago by emitrax

Attachment: echo_path.jpg added

comment:2 Changed 11 years ago by emitrax

Because I thought it could be something terminal related.

Reproducing is just a matter of hitting the command "echo $LIBRARY_PATH". See screenshot attached.

comment:3 Changed 11 years ago by bonefish

Resolution: invalid
Status: newclosed

That looks like it should. "%A" is the placeholder for the application's directory.

Note: See TracTickets for help on using tickets.